PAT A 1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p~1~\^k~1~ * p~2~\^k~2~ *…*p~m~\^k~m~.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p~1~\^k~1~ * p~2~\^k~2~ *…*p~m~\^k~m~, where p~i~’s are prime factors of N in increasing order, and the exponent k~i~ is the number of p~i~ – hence when there is only one p~i~, k~i~ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

#include<cstdio>
#include<cmath>

const int maxn = 100010;
int Prime[maxn], num_p = 0;

struct factor {
    int x, cnt;
}fac[10];

bool isPrime(int n) {
    if (n <= 1) return false;
    int sqr = (int)sqrt(n);
    for (int i = 2; i <=sqr; i++) {
        if (n % i == 0) return false;
    }
    return true;
}

void findPrime(){
    for (int i = 2; i < maxn; i++) {
        if (isPrime(i) == true) {
            Prime[num_p++] = i;
        }
    }
}

int main() {
    int n;
    scanf("%d", &n);
    if (n == 1) printf("1=1\n");
    else {
        printf("%d=", n);
        findPrime();
        int num = 0, sqr = (int)sqrt(n);
        for (int i = 0;  Prime[i] <=sqr ; i++) {
            if (n % Prime[i] == 0) {
                fac[num].x = Prime[i];
                fac[num].cnt = 0;
                while (n % Prime[i] == 0) {
                    fac[num].cnt++;
                    n /= Prime[i];
                }
                num++;
            }
        }
        if (n != 1) {
            fac[num].x = n;
            fac[num++].cnt = 1;
        }

        for (int i = 0; i < num; i++) {
            printf("%d", fac[i].x);
            if (fac[i].cnt > 1) {
                printf("^%d", fac[i].cnt);
            }
            if (i < num - 1) printf("*");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Joah_Ge/article/details/81080450