PAT 1004 Counting Leaves (30 分)

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.


Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.


Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1




解析

要求计算树的每一层叶子结点的数量。
树用静态实现:PAT && 树
遍历用DFS或BFS都行。

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<queue>
#include<string>
#include<cmath>
const int maxn = 101;
using namespace std;
int LayerTable[101]{0};
struct node {
	int layer;
	vector<int> child;
	node() :layer(0) {	}
}Node[maxn];
int BFS() {   // ROOT is 01;
	int maxlayer = 0;
	queue<int> Q;
	Node[1].layer = 0;
	Q.push(1);
	while (!Q.empty()) {
		int temp = Q.front();
		Q.pop();
		if (maxlayer < Node[temp].layer)
			maxlayer = Node[temp].layer;
		if (Node[temp].child.empty())
			LayerTable[Node[temp].layer]++;
		else
			for (auto x : Node[temp].child) {
				Q.push(x);
				Node[x].layer = Node[temp].layer+1;
			}
	}
	return maxlayer;
}
int main() {
	int N, M;
	scanf("%d %d", &N, &M);
	for (int i = 0; i < M; i++) {
		int father, K, son;
		scanf("%d %d", &father, &K);
		for (int i = 0; i < K; i++) {
			scanf("%d", &son);
			Node[father].child.push_back(son);
		}
	}
	int maxlayer = BFS();
	for (int i = 0; i < maxlayer + 1; i++)
		printf("%d%c", LayerTable[i], i == maxlayer  ? '\n' : ' ');
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/84395955