差分数组-P2879 [USACO07JAN]区间统计Tallest Cow

Tallest Cow

Description
FJ’s N (1 ≤ N ≤ 10,000) cows conveniently indexed 1…N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form “cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1…N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

  • Line 1: Four space-separated integers: N, I, H and R

  • Lines 2…R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

Output

  • Lines 1…N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8

Sample Output

5
4
5
3
4
4
5
5
5

Hint
Input Details

There are 9 cows, and the 3rd is the tallest with height 5.
Source
USACO 2007 January Silver
题目:洛谷P2879
翻译来自洛谷:
题目描述:
FarmerJohn 有n头牛,它们按顺序排成一列。 FarmerJohn 只知道其中最高的奶牛的序号及它的高度,其他奶牛的高度都是未知的。现在 FarmerJohn 手上有RR条信息,每条信息上有两头奶牛的序号(aa和bb),其中bb奶牛的高度一定大于等于aa奶牛的高度,且aa,bb之间的所有奶牛的高度都比aa小。现在FarmerJohnFarmerJohn想让你根据这些信息求出每一头奶牛的可能的最大的高度。(数据保证有解)

输入格式:
第1行:四个以空格分隔的整数:nn,ii,hh和RR(nn和RR意义见题面; ii 和 hh 表示第 ii 头牛的高度为 hh ,他是最高的奶牛)

接下来R行:两个不同的整数aa和bb(1 ≤ aa,bb ≤ n)

输出格式:
一共n行,表示每头奶牛的最大可能高度.

数据范围:
1 ≤ n ≤ 10000 ; 1 ≤ h ≤ 1000000 ; 0 ≤ R ≤ 10000)

PS:离线全部查询用差分数组,在线用树状数组

AC代码:

#include<bits/stdc++.h>
using namespace std;
struct node{
	int l;
	int r;
	bool operator < (const node B) const
	{
		if(r!=B.r )
		return r<B.r ;
		return l>B.l ;
	}//优先选择区间小的 
}q[10005];
//离线全部查询用差分数组,在线用树状数组 
int s[10005];
int main(void)
{
	int n,I,h,R;
	scanf("%d %d %d %d",&n,&I,&h,&R);
	for(int i=0;i<R;i++){
		scanf("%d %d",&q[i].l ,&q[i].r );
		if(q[i].l >q[i].r )
		swap(q[i].l ,q[i].r ); 
	}
	sort(q,q+R);
	s[1]=h;
	for(int i=0;i<R;i++){
		if(q[i].l==q[i].r )
		continue;
		//判重 !!!!
		if(q[i].l ==q[i-1].l &&q[i].r ==q[i-1].r )
		continue;
		s[q[i].l+1]--;
		s[q[i].r]++;
	}
	for(int i=1;i<=n;i++){
		s[i]+=s[i-1];
		printf("%d\n",s[i]);
	}
	return 0;
}
发布了68 篇原创文章 · 获赞 15 · 访问量 9003

猜你喜欢

转载自blog.csdn.net/qq_43791377/article/details/103394793
今日推荐