Tallest Cow

问题 G: Tallest Cow

时间限制: 1 Sec  内存限制: 128 MB
提交: 31  解决: 17
[提交] [状态] [讨论版] [命题人:admin]

题目描述

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.
FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.
For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

输入

Line 1: Four space-separated integers: N, I, H and R 
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

输出

Lines 1..N: Line i contains the maximum possible height of cow i.

样例输入

9 3 5 5
1 3
5 3
4 3
3 7
9 8

样例输出

5
4
5
3
4
4
5
5
5

第a个牛可以看见第b个牛,因为要求最大高度,所以只要a到b之间的牛的高度都减一即可

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxx=1e4+100;
const int INF=1e9;
const int MOD=1e8;
struct node
{
    int a,b;
}s[maxx];
bool cmp(node x,node y)
{
    if(x.a==y.a)  return x.b<y.b;
    return x.a<y.a;
}
int ans[maxx];
int main()
{
    int n,p,h,m;
    cin>>n>>p>>h>>m;
    for(int i=1; i<=m; i++){
        cin>>s[i].a>>s[i].b;
        if(s[i].a>s[i].b)  swap(s[i].a,s[i].b);
    }
    sort(s+1,s+n+1,cmp);
    s[0].a=0;
    for(int i=1; i<=n; i++){
        if(s[i].a==s[i-1].a && s[i].b==s[i-1].b)  continue;
        ans[s[i].a+1]--;
        ans[s[i].b]++;
    }
    int cnt=0;
    for(int i=1; i<=n; i++){
        cnt+=ans[i];
        cout<<cnt+h<<endl;
    }
    return 0;
}

(线段树不熟练)

猜你喜欢

转载自blog.csdn.net/renzijing/article/details/81075636