【差分】Tallest Cow

题目

FJ's N(1≤N≤10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H(1≤H≤1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R(0≤R≤10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

Line 1: Four space-separated integers:N,I,H and R Lines 2..R+1: Two distinct space-separated integers A and B(1≤A,B≤N), indicating that cow A can see cow B.

Output

Lines 1..N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5 1 3 5 3 4 3 3 7 9 8

Sample Output

5 4 5 3 4 4 5 5 5

分析

因为让求的是每头牛最高多少,我们先假设每头牛都是最高的,然后输入两个数a,b,表示两个数中的每头牛比两边的小,所以就把从a+1到b-1的牛高度-1;这个题数据范围1e4,可以用差分优化,然后就完了。

代码

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 1e4+5;
int n,m,g,h,a[maxn];
bool v[maxn][maxn];
int main() {
    scanf("%d%d%d%d", &n, &h, &g, &m);
    for(int i = 1; i <= m; i++) {
        int x, y;
        scanf("%d%d", &x, &y);
        if (x > y) swap(x, y);
        if (v[x][y]) continue;
        v[x][y] = 1;
        a[x+1]--,a[y]++;
    }
    for(int i = 1; i <= n; i++)
        a[i] += a[i-1], printf("%d\n", a[i] + g);
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Vocanda/p/12901243.html