HDOJ-1711(kmp算法)

题意描述

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input:
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output
6
-1

思路

不难看出这是一道kmp板子题,直接套模板即可。对于无法匹配的情况,我们可以使用一个标记来记录,需要注意的一点是,输入的值可能会有负数,所以我们要使用int数组来存储a和b两个序列

AC代码

#include<iostream>
#include<algorithm>
#include<cstring>
#define IOS ios::sync_with_stdio(false)
using namespace std;
const int maxn=1e6+10;
const int maxm=10010;
int w[maxm],t[maxn];
int ne[maxm];
int n;
int main(){
    IOS;cin.tie(0);
    cin>>n;
    while(n--){
        int x,y;
        bool flag=true;
        cin>>x>>y;
        for(int i=1;i<=x;i++) cin>>t[i];
        for(int i=1;i<=y;i++) cin>>w[i];
        for(int i=2,j=0;i<=y;i++){
            while(j&&w[i]!=w[j+1]) j=ne[j];
            if(w[i]==w[j+1]) j++;
            ne[i]=j;
        }
        for(int i=1,j=0;i<=x;i++){
            while(j&&t[i]!=w[j+1]) j=ne[j];
            if(t[i]==w[j+1]) j++;
            if(j==y){
                flag=false;
                cout<<i-y+1<<endl;
                break;
            }
        }
        if(flag) cout<<"-1"<<endl;
    }

}

发布了47 篇原创文章 · 获赞 33 · 访问量 2676

猜你喜欢

转载自blog.csdn.net/weixin_45729946/article/details/104502709