HDU2089——不要62 (数位DP)

杭州人称那些傻乎乎粘嗒嗒的人为62(音:laoer)。
杭州交通管理局经常会扩充一些的士车牌照,新近出来一个好消息,以后上牌照,不再含有不吉利的数字了,这样一来,就可以消除个别的士司机和乘客的心理障碍,更安全地服务大众。
不吉利的数字为所有含有4或62的号码。例如:
62315 73418 88914
都属于不吉利号码。但是,61152虽然含有6和2,但不是62连号,所以不属于不吉利数字之列。

你的任务是,对于每次给出的一个牌照区间号,推断出交管局今次又要实际上给多少辆新的士车上牌照了。

Input

输入的都是整数对n、m(0<n≤m<1000000),如果遇到都是0的整数对,则输入结束。

Output

对于每个整数对,输出一个不含有不吉利数字的统计个数,该数值占一行位置。

Sample Input

1 100
0 0

Sample Output

80
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;    
int a[20];    
ll dp[20][2];   
ll dfs(int pos,int state/*表示前一位是否是6*/,bool lead,bool limit)    
{    
    if(pos==-1) return 1;     
    if(!limit && !lead && dp[pos][state]!=-1) return dp[pos][state];   
    int up=limit?a[pos]:9;   
    ll ans=0;    
    //开始计数    
    for(int i=0;i<=up;i++)   
    {    
        if(i == 4)continue;
		if(state && i == 2)continue;    
        ans+=dfs(pos-1,i == 6,lead && i==0,limit && i==a[pos]);       
    }     
    if(!limit && !lead) dp[pos][state]=ans;       
    return ans;    
}    
ll solve(ll x)    
{    
    int pos=0;    
    while(x)//把数位都分解出来    
    {    
        a[pos++]=x%10;//个人老是喜欢编号为[0,pos),看不惯的就按自己习惯来,反正注意数位边界就行    
        x/=10;    
    }    
    return dfs(pos-1,0,true,true);   
}    
int main()    
{    
    ll le,ri;    
    while(~scanf("%lld%lld",&le,&ri) && (le || ri))    
    {    
    	memset(dp,-1,sizeof(dp));
        printf("%lld\n",solve(ri)-solve(le-1));    
    }    
}    




猜你喜欢

转载自blog.csdn.net/vocaloid01/article/details/80355450
今日推荐