POJ-3087- Shuffle'm Up

Shuffle’m Up

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

在这里插入图片描述
The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output
Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

思路:
题目要用到map函数。
以s2的最底端为s12的最底端,从s1和s2中交叉取值(按s2-s1-s2-s1…s2-s1的顺序一次叠加),如果组成的排列与题目最初给的相符合,就输出洗牌的次数,如果不相符合就继续洗牌,让新的s1从s12的最底端开始取值,新的s2是新的s1取剩下的值,如果洗牌顺序不会和题目给出一致,就输出 -1。只要map判断串是否出现过,即可判断是否可行,否则一直循环下去就行。
完整代码:

#include<iostream>
#include<cstring>
#include<map>
using namespace std;
char s1[110];
char s2[110];
char s12[220];
char s[220];
int t;      //编号
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int c;
        cin>>c;
        cin>>s1>>s2>>s12;
        map<string,int>mp;
        int cnt=0;  //换的次数
        t++;        //编号
        int flag=0; //标记
        while(1)
        {
            int len=0;
            cnt++;      //换的次数++
            for(int i=0;i<c;i++)    //换
            {
                s[len]=s2[i];
                len++;
                s[len]=s1[i];
                len++;
            }
            s[len]='\0';
            if(strcmp(s,s12)==0)
            {
                flag=1;
                break;
            }
            if(mp.find(s)!=mp.end())
            {
                break;
            }
            mp[s]=0;
            for(int i=0;i<c;i++)
            {
                s1[i]=s[i];
                s2[i]=s[i+c];
            }
        }
        if(flag)
        {
            cout<<t<<" "<<cnt<<endl;
        }
        else
        {
            cout<<t<<" "<<"-1"<<endl;
        }
    }
    return 0;
}

原题链接:
https://vjudge.net/problem/POJ-3087
http://poj.org/problem?id=3087

发布了60 篇原创文章 · 获赞 69 · 访问量 2839

猜你喜欢

转载自blog.csdn.net/qq_45856289/article/details/104264967