POJ3087 Shuffle'm Up【简单模拟】

Shuffle'm Up

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15665   Accepted: 7143

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (Athrough H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

Source

Greater New York 2006

问题链接:POJ3087 Shuffle'm Up

问题描述:给定s1,s2两副扑克,顺序从下到上。依次将s2,s1的扑克一张一张混合。例如s1=ABC; s2=DEF. 则第一次混合后为DAEBFC。 然后令前半段为s1, 后半段为s2。对于每个测试样例,有两个输出x,y。x表示第几组测试,y:如果可以变换成所给出的字符串,输出变换次数即可;否则,输出-1。

解题思路:简单模拟,关键是怎样判断不能变换成目标字符串,可以使用集合set保存已经变换得到的字符串,如果再次出现说明继续转换也不能成功。

AC的C++程序:

#include<iostream>
#include<string>
#include<set>

using namespace std;

int main()
{
	int T,len;
	cin>>T;
	for(int t=1;t<=T;t++){
		string s1,s2,s,p;
		set<string>S;//存储已经出现过的字符串 
		cin>>len>>s1>>s2>>s;
		int count=0;
		cout<<t<<" ";
		for(;;){
			//进行一次转换 
			p=s1+s2;
			for(int i=0;i<len;i++){
				p[i*2+1]=s1[i];
				p[i*2]=s2[i];
			}
			count++;//转换的次数加一 
			if(p==s){//成功,输出次数并退出 
				cout<<count<<endl;
				break; 
			}
			else if(S.count(p)){//失败,而且p已经出现过了,继续转换也不能成功 
				cout<<"-1"<<endl;
				break;
			}
			else{//失败,但是转换的字符串还未出现过,就加入S中,并使更新s1和s2的值 
				S.insert(p);
				s1=p.substr(0,len);
				s2=p.substr(len,len);
			}
		}
	}
	return 0; 
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/83088819