POJ-3087___Shuffle'm Up——解题报告

原题地址:http://poj.org/problem?id=3087

Shuffle'm Up
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13338   Accepted: 6173

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1


题目大意:

给出两堆牌s1、s2,交叉相叠(s2最底牌在最下面),即进行一次操作,若与目标排序不相同,则分上半为s1,下半为s2,继续进行操作。问最少进行几次或无法达到目的?


解题思路:

用string字符串操作即可,同时用map映射记录已作出的新排序,若出现重复则说明循环


代码思路:

1、用两组string存储待相叠的卡牌序和相叠后的卡牌序

2、用map记录已出现过的合序

3、若出现重复则退出,不出现则继续进行操作


核心:本题关键在于如何判断始终无法达到最终目的!则判断操作是否出现重复即可!


代码:

#include <iostream>
#include <string.h>
#include <map>
#include <string>
using namespace std;
string s1,s2,s;
string str1,str2,str;

int main()
{
	std::ios::sync_with_stdio(false);
	int T,k=0;
	cin>>T;
	while(T--)
	{
		int n;
		cin>>n;
		cin>>s1>>s2>>s;
		map<string,bool>p;
		p.clear();
		p[s1]=1;
		p[s2]=1;
		str1=s1;
		str2=s2;
		int flag = 1;
		int t=0;
		while(flag)
		{
			t++;
			str="";
			for(int i=0;i<n;i++)
			{
				str+=str2[i];
				str+=str1[i];
			}
			if(str==s)
			{
				flag=0;
				cout<<++k<<" "<<t<<endl;
			}
			else if(p[str]==1)
			{
				flag=0;
				cout<<++k<<" -1"<<endl;
			}
			else
			{
				str1 = "";  
            	str2 = "";
			{
				for(int i=0;i<n;i++)
					str1+=str[i];
				for(int i=n;i<=2*n;i++)
					str2+=str[i];
			}
			}
			p[str]=1;	
		}
	 } 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/scar_halo/article/details/79416754
今日推荐