poj 3087 Shuffle'm Up(dfs 模拟)

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

题目大意:
给定两个长度为len的字符串s1和s2, 接着给出一个长度为len*2的字符串s12。将字符串s1和s2通过一定的变换变成s12,找到变换次数, 输出变化次数。如果不能变化成s12的形式就输出-1。

题解:
直接按照题目要求进行模拟就可。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int N = 110;
int len;
char a[N];
char b[N];
char a1[N];
char b1[N];
char temp[2*N];
char s[2*N];

int dfs(int n){
    if(strcmp(temp, s) == 0){
        //cout << 1 << endl;
        return n;
    }
    if(strcmp(a1, a) == 0 || strcmp(b1, b) == 0){
      // cout << 2 << endl;
        return -1;
    }
    for(int i = 0; i < len; i++){
        a1[i] = temp[i];
    }
    a1[len] = '\0';//注意这个地方,给他手工添结束符,不然会造成死循环~
    //printf("%s\n", a1);
    int j = 0;
    for(int i = len; i < 2*len; i++){
        b1[j++] = temp[i];
    }
    b1[len] = '\0';//注意这个地方,给他手工添结束符,不然会造成死循环~
    //printf("%s\n", b1);
    j = 0;
    for(int i = 0; i < len; i++){
        temp[j++] = b1[i];
        temp[j++] = a1[i];
    }
    //printf("%s\n", temp);
    dfs(n+1);
}

int main(){
    int t, sum, cnt = 1;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &len);
        scanf("%s", a);
        scanf("%s", b);
        scanf("%s", s);
        int j = 0;
        for(int i = 0; i < len; i++){
            temp[j++] = b[i];
            temp[j++] = a[i];
        }
        temp[j] = '\0';
        sum = dfs(1);
        printf("%d %d\n", cnt++, sum);
    }
    //system("pause");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/81381005