Shuffle'm Up POJ - 3087

Shuffle'm Up
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13495   Accepted: 6250

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2ndchip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips fromS12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (Athrough H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

Source

Greater New York 2006

题意:给三个字符串长为m的s1,s2以及长为2*m的s12,s12是最终要达到的目标,s1和s2是初始的值,按照s2先放,s1后放的规则,依次存放构成新的序列ss12,如果该序列与最终目标相同,则输出总共的步数,新的s1会变成ss12的前m个并且顺序为0....m-1,新的s2会变成ss12的后m个并且顺序为m....2*m-1。注意题意,不能颠倒。在做题的时候就是理解错题意导致错误。

 
 
#include<iostream>
#include<cstring>
using namespace std;
string s1,s2,s12,temp,str1;
int n,m,sum;
int main(){
	ios::sync_with_stdio(false); 
	cin >> n;
	bool flag;
	for(int i=0;i<n;i++){
		cin >> m;
		cin >> s1;
		cin >> s2;
		cin >> s12;
		temp=s12;
		str1=s1;
		flag=true;
		sum=0;
		while(flag){
			int k=0;
			for(int j=0;j<m;j++){//按规则建新的s12
				temp[k++]=s2[j];
				temp[k++]=s1[j];
			}
			sum++;
			if(!s12.compare(temp)){//如果找到与目标相同的则退出循环
				break;
			}
			for(int j=0;j<m;j++){//建立新的s1和s2
				s1[j]=temp[j];
				s2[j]=temp[m+j];
			}
			if(!s1.compare(str1)){//如果新的s1与开始的s1相同,那么就成了循环,输出-1
				flag=false;
			}
		}
		if(flag){
			cout << (i+1) << " " << sum << endl;
		}else{
			cout << (i+1) << " " << "-1" << endl;
		}
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_39513105/article/details/79599496