蓝桥杯 算法训练 关联矩阵 (java)

算法训练 关联矩阵  
时间限制:1.0s   内存限制:512.0MB
    
问题描述
  有一个n个结点m条边的有向图,请输出他的关联矩阵。
输入格式
  第一行两个整数n、m,表示图中结点和边的数目。n<=100,m<=1000。
  接下来m行,每行两个整数a、b,表示图中有(a,b)边。
  注意图中可能含有重边,但不会有自环。
输出格式
  输出该图的关联矩阵,注意请勿改变边和结点的顺序。
样例输入
5 9
1 2
3 1
1 5
2 5
2 3
2 3
3 2
4 3
5 4
样例输出
1 -1 1 0 0 0 0 0 0
-1 0 0 1 1 1 -1 0 0
0 1 0 0 -1 -1 1 -1 0
0 0 0 0 0 0 0 1 -1
0 0 -1 -1 0 0 0 0 1

这道题只要会什么是关联矩阵就行。

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
       Scanner sc=new Scanner(System.in);
       int n=sc.nextInt();
       int m=sc.nextInt();
       int[][] c=new int[n+1][m+1];
       for(int i=1;i<=m;i++){
    	   int a=sc.nextInt();
    	   int b=sc.nextInt();
    	   c[a][i]=1;
    	   c[b][i]=-1;
       }
       for(int i=1;i<=n;i++){
    	   System.out.print(c[i][1]);
    	   for(int j=2;j<=m;j++){
    		   System.out.print(" "+c[i][j]);
    	   }
    	   System.out.println();
       }

	}

}

猜你喜欢

转载自blog.csdn.net/hui_1997/article/details/80173961