UVA167 LA5727 HDU1642 The Sultan's Successors【DFS】

The Sultan of Nubia has no children, so she has decided that the country will be split into up to k separate parts on her death and each part will be inherited by whoever performs best at some test. It is possible for any individual to inherit more than one or indeed all of the portions. To ensure that only highly intelligent people eventually become her successors, the Sultan has devised an ingenious test. In a large hall filled with the splash of fountains and the delicate scent of incense have been placed k chessboards. Each chessboard has numbers in the range 1 to 99 written on each square and is supplied with 8 jewelled chess queens. The task facing each potential successor is to place the 8 queens on the chess board in such a way that no queen threatens another one, and so that the numbers on the squares thus selected sum to a number at least as high as one already chosen by the Sultan. (For those unfamiliar with the rules of chess, this implies that each row and column of the board contains exactly one queen, and each diagonal contains no more than one.)
    Write a program that will read in the number and details of the chessboards and determine the highest scores possible for each board under these conditions. (You know that the Sultan is both a good chess player and a good mathematician and you suspect that her score is the best attainable.)
Input
Input will consist of k (the number of boards), on a line by itself, followed by k sets of 64 numbers, each set consisting of eight lines of eight numbers. Each number will be a positive integer less than 100. There will never be more than 20 boards.
Output
Output will consist of k numbers consisting of your k scores, each score on a line by itself and right justified in a field 5 characters wide.
Sample Input
1
1 2 3 4 5 6 7 8
9 10 11 12 13 14 15 16
17 18 19 20 21 22 23 24
25 26 27 28 29 30 31 32
33 34 35 36 37 38 39 40
41 42 43 44 45 46 47 48
48 50 51 52 53 54 55 56
57 58 59 60 61 62 63 64
Sample Output
    260

问题链接UVA167 LA5727 HDU1642 The Sultan’s Successors
问题简述:(略)
问题分析:八皇后问题,用DFS来解决,不解释。
程序说明:程序在LA5727中出现WA,在HDU1642中出现TLE,搞不明白啊!
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA167 LA5727 HDU1642 The Sultan's Successors */

#include <bits/stdc++.h>

using namespace std;

const int N = 8;
int grid[N][N], pos[N], ans, cnt;

bool judge(int row, int col)
{
    for(int i = 0; i < row; i++)
        if(pos[i] ==col || abs(col - pos[i]) == abs(row - i))
            return false;
    return true;
}

void dfs(int row)
{
    if(row >= N) {
        if(cnt > ans) ans = cnt;
    }

    for(int i = 0; i < N; i++)
        if(judge(row, i)) {
            pos[row] = i;
            cnt += grid[row][i];
            dfs(row + 1);
            cnt -= grid[row][i];
        }
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--) {
        ans = cnt = 0;
        for(int i = 0; i < N; i++)
            for(int j = 0; j < N; j++)
                scanf("%d", &grid[i][j]);

        dfs(0);

        printf("%5d\n", ans);
    }

    return 0;
}
发布了2131 篇原创文章 · 获赞 2306 · 访问量 254万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/104600234
今日推荐