Jury Compromise(DP)

Jury Compromise

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury.
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties.
We will now make this more precise: given a pool of n potential jurors and two values di (the defence's value) and pi (the prosecution's value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,..., n} with m elements, then D(J ) = sum(dk) k belong to J
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution.
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties.
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.
Input
The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members.
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,...,n. A blank line separates each round from the next.
The file ends with a round that has n = m = 0.
Output
For each round output a line containing the number of the jury selection round ('Jury #1', 'Jury #2', etc.).
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number.
Output an empty line after each test case.
Sample Input
4 2 
1 2 
2 3 
4 1 
6 2 
0 0 
Sample Output
Jury #1 
Best jury has value 6 for prosecution and value 4 for defence: 
 2 3 
Hint
If your solution is based on an inefficient algorithm, it may not execute in the allotted time.

网上有很多二维dp的题解实际是不正确的,下面这一篇博客是更加优化的二维dp可以通过更强的数据

传送门

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
int dp[21][801];//dp[i][j]代表选择i的人,他们的差值是j的d+p的和的最大值
vector<int> path[21][801];
int main(){
    int cas = 1;
    int sub[201],plu[201];//距离d和p的差,和
    int n,m,i,j,k;
    while(~scanf("%d%d",&n,&m) && n && m){
        for(i = 0; i < m; i++){
            for(j = 0; j < 801; j++){
                path[i][j].clear();
            }
        }
        memset(dp,-1,sizeof(dp));
        int d,p;
        for(int i = 0; i < n; i++){
            cin >> d >> p;
            sub[i] = d - p;
            plu[i] = d + p;
        }
        int fix = 20 * m;//修正值,保证不越界
        dp[0][fix] = 0;//相当于真正的dp[0][0]
        for(k = 0; k < n; k++){//选一个
            for(i = m-1; i >= 0; i--){//进行逆推
                for(j = 0; j < 2*fix; j++){
                    if(dp[i][j] >= 0){
                        if(dp[i+1][j+sub[k]] <= dp[i][j] + plu[k]){//比原本大更新,因为要选和的最大值
                            dp[i+1][j+sub[k]] = dp[i][j] + plu[k];
                            path[i+1][j+sub[k]] = path[i][j];//每次更新都要把上一步的路径全部复制过来
                            path[i+1][j+sub[k]].push_back(k);
                        }
                    }
                }
            }
        }
        for(i = 0; dp[m][fix+i] == -1 && dp[m][fix-i] == -1; i++);
        //枚举差值从0开始,因为要是差值尽量小;当遇到第一个不为-1时停止,之前更新保证了每个dp值都是该情况下的和的最大值
        int temp = (dp[m][fix+i] > dp[m][fix-i]) ? i : -i;//确定下差值
        int sumD = (dp[m][fix+temp] + temp) / 2;//sumD = ((sumD + sumP) + sumD - sumP)/2 = 2sumD / 2
        int sumP = (dp[m][fix+temp] - temp) / 2;//sumP = ((sumD + sumP) - (sumD - sumP))/2 = 2sumP / 2;
        printf("Jury #%d\n",cas++);
        printf("Best jury has value %d for prosecution and value %d for defence:\n",sumD,sumP);
        for(int i = 0; i < m; i++){
            printf(" %d",path[m][fix+temp][i]+1);
        }
        printf("\n\n");
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/80371817