DP专题-------K - Jury Compromise DP

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury.
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties.
We will now make this more precise: given a pool of n potential jurors and two values di (the defence’s value) and pi (the prosecution’s value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,…, n} with m elements, then D(J ) = sum(dk) k belong to J
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution.
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties.
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.
Input
The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members.
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,…,n. A blank line separates each round from the next.
The file ends with a round that has n = m = 0.
Output
For each round output a line containing the number of the jury selection round (‘Jury #1’, ‘Jury #2’, etc.).
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number.
Output an empty line after each test case.
Sample Input
4 2
1 2
2 3
4 1
6 2
0 0
Sample Output
Jury #1
Best jury has value 6 for prosecution and value 4 for defence:
2 3
Hint
If your solution is based on an inefficient algorithm, it may not execute in the allotted time.

类似背包的做法,利用了滚动数组从三维优化到了二维
dp[i][j]代表当前已选i个时 |D(J) - P(J)|为j时的 |D(J) + P(J)|和最大是多少;
又因为j的数j >= -20 * m && j <= 20 * m;所以对于每个j值 + 20 * m,来保证都为正数;
dp[i + 1][j + sub[k] = max(dp[i + 1][j + sub[k],dp[i][j] + sum[k]);
又因为每个最多可去一次,所以需要仿照背包一样,逆着遍历i值,从m - 1 到 0;
如果正着遍历的话,会多次采用当前第k项;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define mp make_pair
#define pb push_back
#define fi first
#define se second

int sub[205];
int sum[205];
int dp[25][1005];
vector<int>path[25][1005];

int main()
{
    int n,m;
    int cnt = 0;
    while(~scanf("%d %d",&n,&m)){
        if(n == 0 && m == 0) break;
        for(int i = 0;i < 20;++i){
            for(int j = 0;j < 805;++j){
                path[i][j].clear();
            }
        }
        memset(dp,-1,sizeof(dp));
        for(int i = 0;i < n;++i){
            int a,b;
            scanf("%d %d",&a,&b);
            sub[i] = a - b;
            sum[i] = a + b;
        }
        int tmp = 20 * m;    //因为最后的D - P >= -20 * m && D - p <= 20 * m
        dp[0][tmp] = 0;
        for(int k = 0;k < n;++k){
            for(int i = m - 1;i >= 0;--i){
                for(int j = 0;j < 2 * tmp;++j){
                    if(dp[i][j] >= 0){
                        if(dp[i][j] + sum[k] >= dp[i + 1][j + sub[k]]){
                            dp[i + 1][j + sub[k]] = dp[i][j] + sum[k];
                            path[i + 1][j + sub[k]] = path[i][j];
                            path[i + 1][j + sub[k]].pb(k);
                        }
                    }
                }
            }
        }
        //找到第一个差存在的,有一个dp[m][tmp + p],dp[m][tmp - p]有一个成立,即存在解
        int p;
        for(p = 0;dp[m][tmp - p] == -1 && dp[m][tmp + p] == -1;++p);
        int id = (dp[m][tmp + p] > dp[m][tmp - p]) ? p : -p;   //代表D(J) - P(J)
        int sumD = (dp[m][tmp + id] + id) / 2;   //dp[m][tmp + id]代表D(J) + P(J)
        int sumP = (dp[m][tmp + id] - id) / 2;
        printf("Jury #%d\n",++cnt);
        printf("Best jury has value %d for prosecution and value %d for defence:\n",sumD,sumP);
        int len = path[m][tmp + id].size();
        for(int i = 0;i < len;++i){
            printf(" %d",path[m][tmp + id][i] + 1);
        }
        printf("\n\n");
    }
    return 0;
}

发布了269 篇原创文章 · 获赞 33 · 访问量 8万+

猜你喜欢

转载自blog.csdn.net/qq_36386435/article/details/89066200