poj1015 Jury Compromise

Jury Compromise
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30805   Accepted: 8263   Special Judge

Description

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury. 
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties. 
We will now make this more precise: given a pool of n potential jurors and two values di (the defence's value) and pi (the prosecution's value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,..., n} with m elements, then D(J ) = sum(dk) k belong to J 
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution. 
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties. 
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.

Input

The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members. 
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,...,n. A blank line separates each round from the next. 
The file ends with a round that has n = m = 0.

Output

For each round output a line containing the number of the jury selection round ('Jury #1', 'Jury #2', etc.). 
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number. 
Output an empty line after each test case.

Sample Input

4 2 
1 2 
2 3 
4 1 
6 2 
0 0 

Sample Output

Jury #1 
Best jury has value 6 for prosecution and value 4 for defence: 
 2 3 

Hint

If your solution is based on an inefficient algorithm, it may not execute in the allotted time.


大致题意:

在遥远的国家佛罗布尼亚,嫌犯是否有罪,须由陪审团决定。陪审团是由法官从公众中挑选的。先随机挑选n 个人作为陪审团的候选人,然后再从这n 个人中选m 人组成陪审团。选m 人的办法是:控方和辩方会根据对候选人的喜欢程度,给所有候选人打分,分值从0 到20。为了公平起见,法官选出陪审团的原则是:选出的m 个人,必须满足辩方总分D控方总分P的差的绝对值|D-P|最小。如果有多种选择方案的 |D-P| 值相同,那么选辩控双方总分之和D+P最大的方案即可。

输出:

选取符合条件的最优m个候选人后,要求输出这m个人的辩方总值D和控方总值P,并升序输出他们的编号。


解题思路:

动态规划。


      为叙述问题方便,现将任一选择方案中,辩方总分和控方总分之差简称为“辩控差”,辩方总分和控方总分之和称为“辩控和”。第i 个候选人的辩方总分和控方总分之差记为V(i),辩方总分和控方总分之和记为S(i)。

现用dp(j, k)表示,取j 个候选人,使其辩控差为k 的所有方案中,辩控和最大的那个方案(该方案称为“方案dp(j, k)”)的辩控和。

并且,我们还规定,如果没法选j 个人,使其辩控差为k,那么dp(j, k)的值就为-1,也称方案dp(j, k)不可行。本题是要求选出m 个人,那么,如果对k 的所有可能的取值,求出了所有的dp(m, k) (-20×m≤ k ≤ 20×m),那么陪审团方案自然就很容易找到了。
    问题的关键是建立递推关系。需要从哪些已知条件出发,才能求出dp(j, k)呢?显然,方案dp(j, k)是由某个可行的方案dp(j-1, x)( -20×m ≤ x ≤ 20×m)演化而来的。

可行方案dp(j-1, x)能演化成方案dp(j, k)的必要条件是:存在某个候选人i,i 在方案dp(j-1, x)中没有被选上,且x+V(i) = k。在所有满足该必要条件的dp(j-1, x)中,选出 dp(j-1, x) + S(i) 的值最大的那个,那么方案dp(j-1, x)再加上候选人i,就演变成了方案 dp(j, k)。

这中间需要将一个方案都选了哪些人都记录下来。不妨将方案dp(j, k)中最后选的那个候选人的编号,记在二维数组的元素path[j][k]中。那么方案dp(j, k)的倒数第二个人选的编号,就是path[j-1][k-V[path[j][k]]]。假定最后算出了解方案的辩控差是k,那么从path[m][k]出发,就能顺藤摸瓜一步步回溯求出所有被选中的候选人。

初始条件,只能确定dp(0, 0) = 0,其他均为-1。由此出发,一步步自底向上递推,就能求出所有的可行方案dp(m, k)( -20×m ≤ k ≤ 20×m)。实际解题的时候,会用一个二维数组dp 来存放dp(j, k)的值。而且,由于题目中辩控差的值k 可以为负数,而程序中数租下标不能为负数,所以,在程序中不妨将辩控差的值都加上修正值fix=400,以免下标为负数导致出错。

为什么fix=400?这是很显然的,m上限为20人,当20人的d均为0,p均为20时,会出现辨控差为-400。修正后回避下标负数问题,区间整体平移,从[-400,400]映射到[0,800]。

此时初始条件修正为dp(0, fix) = 0,其他均为-1。

DP后,从第m行的dp(m, fix)开始往两边搜索最小|D-P| 即可,第一个不为dp[m][k]!=-1的位置k就是最小|D-P|的所在。

最后就是求m个人的D和P,由于D+P = dp(m, |D-P| ) ,|D-P|已知。

那么D= (D+P + |D-P| )/2  ,  P=(D+P-|D-P| ) / 2

计算D和P时注意修正值fix


tips:dp(j,k)代表的意义  j当前正在选第j个候选人,k当前的辩控差总和为k,dp(j,k) 当前最大的辩控和

然后不断更新的是dp(j,k)的值。


ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

int n,m;
int dp[25][1000];
int path[25][1000];
int d[205];
int p[205];
int dpc[205];
int dpsum[205];

bool dis(int j,int k,int i,int v[205])
{
    while(j > 0 && path[j][k] != i)
    {
        k -= v[path[j][k]];
        j--;
    }
    return j?false:true;
}

int main()
{
    int t = 1;
    while(~scanf("%d %d",&n,&m)&&n&&m)
    {
        memset(dp,-1,sizeof(dp));
        memset(path,0,sizeof(path));
        memset(d,0,sizeof(d));
        memset(p,0,sizeof(p));
        memset(dpc,0,sizeof(dpc));
        memset(dpsum,9,sizeof(dpsum));

        for(int i = 1; i <= n; i++)
        {
            scanf("%d %d",&d[i],&p[i]);
            dpc[i] = d[i] - p[i];
            dpsum[i] = d[i] + p[i];
        }

        int fix = m*20;
        dp[0][fix] = 0;

        for(int j = 1; j <= m; j++)
        {
            for(int k = 0; k <= 2*fix; k++)
            {
                if(dp[j-1][k] >= 0)
                {
                    for(int i = 1; i <= n; i++)
                    {
                        if(dp[j][k+dpc[i]] < dp[j-1][k] + dpsum[i])//有更好的情况
                        {
                            if(dis(j-1,k,i,dpc))//判断当前编号是否已经编入
                            {
                                dp[j][k+dpc[i]] = dp[j-1][k] + dpsum[i];
                                path[j][k+dpc[i]] = i;
                            }
                        }
                    }
                }
            }
        }

        int div;
        for(int k=0;k<=fix;k++)
            {
                if(dp[m][fix-k]>=0 || dp[m][fix+k]>=0)    //从中间向两边搜索最小辨控差的位置k
                {
                    div=dp[m][fix-k] > dp[m][fix+k] ? (fix-k):(fix+k);  //最小辨控差
                    break;
                }
            }



        cout<<"Jury #"<<t++<<endl;
        cout<<"Best jury has value ";
        //辩方总值 = (辨控和+辨控差+修正值)/2
        cout<<(dp[m][div]+div-fix)/2<<" for prosecution and value ";
        //控方总值 = (辨控和-辨控差+修正值)/2
        cout<<(dp[m][div]-div+fix)/2<<" for defence:"<<endl;

        int* id=new int[m];
        for(int i=0,j=m,k=div;i<m;i++)
        {
            id[i]=path[j][k];
            k-= dpc[ id[i] ];
            j--;
        }
        sort(id,id+m);   //升序输出候选人编号
        for(int i=0;i<m;i++)
            cout<<' '<<id[i];
        cout<<endl<<endl;
        delete id;

    }
    return 0;
}




猜你喜欢

转载自blog.csdn.net/ac_blood/article/details/79882420