HDU 1151Air Raid 最小路径重复点覆盖

一、内容

 Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input
Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

二、思路

  • 求出最少的路径将所有点覆盖至少一次。 那么就是求出最小重复点覆盖 = 总点数 - 最大匹配数。

三、代码

#include <cstdio>
#include <cstring>
using namespace std;
const int N = 1005;
int t, n, m, u, v, g[N][N], mat[N];
bool vis[N];
bool dfs(int u) {
	for (int v = 1; v <= n; v++) {
		if (vis[v] || !g[u][v]) continue;
		vis[v] = true;
		if (!mat[v] || dfs(mat[v])) {
			mat[v] = u; return true;
		}
	}
	return false;
}
int main() {
	scanf("%d", &t); 
	while (t--) {
		memset(g, 0, sizeof(g));
		memset(mat, 0, sizeof(mat));
		scanf("%d%d", &n, &m);
		for (int i = 1; i <= m; i++) {
			scanf("%d%d", &u, &v);
			g[u][v] = 1;
		}
		//求传递闭包
		for (int k = 1; k <= n; k++) {
			for (int i = 1; i <= n; i++) {
				for (int j = 1; j <= n; j++) g[i][j] |= g[i][k] && g[k][j];
			}
		}
		//求最大匹配
		int ans = 0;
		for (int i = 1; i <= n; i++) {
			memset(vis, false, sizeof(vis));
			if (dfs(i)) ans++;
		} 
		printf("%d\n", n - ans);
	} 
	
	return 0;
} 
发布了471 篇原创文章 · 获赞 481 · 访问量 7万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/104521657