HDU - 1698 Just a Hook(线段树区间更新 替换值)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 42212    Accepted Submission(s): 20314


 

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
 



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.  

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

 

Sample Input

 

1 10 2 1 5 2 5 9 3

 

Sample Output

 

Case 1: The total value of the hook is 24.

 

Source

2008 “Sunline Cup” National Invitational Contest

 

Recommend

wangye

线段树板子题,区间[x,y]内的值都变成z;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
#define maxn 100010
#define ison l,mid,rt<<1
#define lson mid+1,r,rt<<1|1
int tree[maxn<<2],vis[maxn<<2]={0};
int n,q;

void build(int l,int r,int rt){
	if(l == r){
		tree[rt] = 1;
		return;
	}
	int mid = (l+r)>>1;
	build(ison);
	build(lson);
	tree[rt] = tree[rt<<1] + tree[rt<<1|1];
}

void solve(int l,int r,int rt){
	if(vis[rt] == 0)  return;
	int mid = (l+r)>>1;
	tree[rt<<1] = vis[rt]*(mid+1-l);
	tree[rt<<1|1] = vis[rt]*(r-mid);
	vis[rt<<1] = vis[rt<<1|1] = vis[rt];
	vis[rt] = 0;
}

void updata(int x,int y,int z,int l,int r,int rt){//将[x,y]内的值替换成z
	if(x <= l && r <= y){
		tree[rt] = z*(r+1-l);
		vis[rt] = z;//直接将区间里的值替换成z,所以不能加;
		return;//一定要有return,不然系统会崩溃;
	}
	solve(l,r,rt);
	int mid = (l+r)>>1;
	if(x <= mid)  updata(x,y,z,ison);
	if(y > mid)  updata(x,y,z,lson);
	tree[rt] = tree[rt<<1] + tree[rt<<1|1];
}

int main(){
	int t;
	scanf("%d",&t);
	for(int i=1;i<=t;i++){
        memset(vis,0,sizeof(vis));//注意,每次一定要把标记清零;
		scanf("%d%d",&n,&q);
		build(1,n,1);
		while(q--){
			int x,y,z;
			scanf("%d%d%d",&x,&y,&z);
			updata(x,y,z,1,n,1);
		}
		printf("Case %d: The total value of the hook is %d.\n",i,tree[1]);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42754600/article/details/81394154