1011.World Cup Betting (20)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

扫描二维码关注公众号,回复: 1052890 查看本文章
T T W 37.98

思路

要输入三行数字,分别是W\T\L的数字,选取每一行中最大的那个数字,并记录其字母,用sum累乘,最后再根据公式计算


C++:

#include "cstdio"
#include "algorithm"
#include "iostream"

using namespace std;

char game[3]={'W','T','L'};

int main(){
	double temp;
	char a[3]={};//记录 w t l
	double max=0.0,sum=1.0;
	int index=0;
	for (int i=0;i<3;i++)
	{
		cin>>max;
		a[i]=game[0];
		for (int j=1;j<3;j++)
		{
			cin>>temp;
			if(temp>max){
				max=temp;
				a[i]=game[j];
			}
		}
		sum*=max;
	}
	sum=((sum*0.65)-1)*2;
	for (int i=0;i<3;i++)
	{
		cout<<a[i]<<" ";
	}
	printf("%.2f",sum);
	return 0;
}



猜你喜欢

转载自blog.csdn.net/ysq96/article/details/80375832
今日推荐