PAT 甲级 1135 Is It A Red-Black Tree (30 分) 二刷 根+红结点孩子均为黑色+dfs

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
在这里插入图片描述在这里插入图片描述在这里插入图片描述
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int N;
int a,k;
bool flag=false;
int black;
bool visit[50];
struct node{
    int data;
    node *lchild,*rchild;
};
void insert_Tree(node* &curr,int a)
{
    if(curr==NULL)
    {
        curr=new node;
        curr->data=a;
        curr->lchild=NULL;
        curr->rchild=NULL;
        return;
    }
    if( abs(a) < abs(curr->data))
        insert_Tree( curr->lchild,a );
    else
        insert_Tree( curr->rchild,a );
}
void preorder(node* curr)
{
    if(curr!=NULL)
    {
            if(curr->lchild)
            {
                if(curr->data<0 && curr->lchild->data < 0)
                    flag=true;
                else
                    preorder(curr->lchild);
            }
            if(curr->rchild)
            {
                if(curr->data<0 && curr->rchild->data <0)
                    flag=true;
                else
                    preorder(curr->rchild);
            }
    }
}
void dfs(node *curr,int b)
{
    if(curr==NULL) //当前到达叶子结点
    {
        if(black==-1)
            black=b;
        else if(black!=b)
            flag=true;
        return;
    }
    if(curr->data > 0 )
        b++;
    dfs(curr->lchild,b);
    dfs(curr->rchild,b);
}
int main(){
    scanf("%d",&N);
    while(N--)
    {
        scanf("%d",&k);
        node *root=NULL;
        black=-1;
        fill(visit,visit+50,false);
        flag=false;
        for(int i=1;i<=k;i++)
        {
            scanf("%d",&a);
            insert_Tree(root,a);
        }
        if(root->data < 0) //根结点是红色结点
        {
            printf("No\n");
            continue;
        }
        preorder(root);
        if(flag)
        {
            printf("No\n");
            continue;
        }
        flag=false;
        dfs(root,0);
        if(flag)
           printf("No\n");
        else
           printf("Yes\n");
    }
    return 0;
}

发布了174 篇原创文章 · 获赞 18 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_41173604/article/details/100530595