【PAT】A1135 Is It A Red-Black Tree (30point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1135 Is It A Red-Black Tree (30point(s))

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpg rbf2.jpg rbf3.jpg
Figure 1 Figure 2 Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

Code

#include <bits/stdc++.h>
using namespace std;
struct NODE{
    int data;
    struct NODE *lchild,*rchild;
};
vector<int> pre,in;
bool cmp(int a,int b){return abs(a)<abs(b);}
NODE *build(int preL,int preR,int inL,int inR){
    if(preL>preR)   return NULL;
    NODE *root=new NODE;
    root->data=pre[preL];
    int i;
    for(i=inL;i<=inR;i++){
        if(pre[preL]==in[i]){
            break;
        }
    }
    int lcnt=i-inL;
    root->lchild=build(preL+1,preL+lcnt,inL,i-1);
    root->rchild=build(preL+lcnt+1,preR,i+1,inR);
    return root;
}
bool dfs(NODE *root){	// 判断条件4
    if(root==NULL)  return true;
    if(root->data<0){
        if(root->lchild!=NULL&&root->lchild->data<0)    return false;
        if(root->rchild!=NULL&&root->rchild->data<0)    return false;
    }
    return dfs(root->lchild)&&dfs(root->rchild);
}
int getBlack(NODE *root,bool &f){	// 判断条件5
    if(root==NULL)  return 0;
    int l=getBlack(root->lchild,f);
    int r=getBlack(root->rchild,f);
    if(l!=r)    f=false;
    if(root->data>0){
        return max(l,r)+1;
    }
    return max(l,r);
}
int main(){
    int k,n;
    cin>>k;
    while(k--){
        cin>>n;
        bool flag=true;
        pre.resize(n);
        in.resize(n);
        for(int i=0;i<n;i++)    cin>>pre[i];
        in=pre;
        sort(in.begin(),in.end(),cmp);
        NODE *root=build(0,n-1,0,n-1);
        getBlack(root,flag);
        if(root->data<0||dfs(root)==false||flag==false) printf("No\n");
        else    printf("Yes\n");
    }
    return 0;
}

Analysis

-已知一棵树的先序,正数表示黑,负数表示红。

-我们知道红黑书是一颗二叉排序树,我们可以先对先序进行排序得到中序,然后用先序和中序建树。然后对2.4.5这3个条件进行判断。(1和3是规定)

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103902196