1135 Is It A Red-Black Tree 1135 Is It A Red-Black Tree(30 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Puppettt/article/details/82144767

1135 Is It A Red-Black Tree(30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpg rbf2.jpg rbf3.jpg
Figure 1 Figure 2 Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

题意:

红黑树是平衡二叉搜索树的一种,满足以下条件

1.每个节点非黑即红

2.根结点是黑色的

3.每个叶(空)节点是黑色的 【这个条件我至今不知道什么用.....不是很明白】

4.如果一个结点是红色,则它的孩子结点一定是黑的【即没有两个连续的红色结点】

5.满足每个左右子树黑色结点数相同

思路:

1.建平衡二叉树

2.判断是否有连续的红色结点

3.判断左右子树黑色结点数是否相同

代码:

#include <bits/stdc++.h>
using namespace std;
typedef struct node{
    int v;
    struct node *left,*right;
}Node;
int a[33];
int getBlackNum(Node*tre)
{
    if(tre==NULL)return 0;
    int l=getBlackNum(tre->left);
    int r=getBlackNum(tre->right);
    if(tre->v>0)
    {
        return max(l,r)+1;
    }
    else{
        return max(l,r);
    }
}
Node*Insert(Node*tre,int val)
{
    if(tre==NULL)
    {
        tre=new Node();
        tre->v=val;
        return tre;
    }
    if(abs(val)<=abs(tre->v))//插在左子树
    {
        tre->left=Insert(tre->left,val);
    }
    else{
        tre->right=Insert(tre->right,val);
    }
    return tre;
}
bool judgeRed(Node*tre)
{
    if(tre==NULL)return true;
    //Red Red
    if(tre->v<0){
    if(tre->left!=NULL&&tre->left->v<0)return false;
    if(tre->right!=NULL&&tre->right->v<0)return false;
    }
    return judgeRed(tre->left)&&judgeRed(tre->right);
}
bool judgeNum(Node*tre)
{
    if(tre==NULL)return true;
    int l=getBlackNum(tre->left);
    int r=getBlackNum(tre->right);
    if(l!=r)return false;
    return judgeNum(tre->left)&&judgeNum(tre->right);
}
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        int n;scanf("%d",&n);
        Node *tre=NULL;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            tre=Insert(tre,a[i]);
        }
        if(a[0]>0&&judgeNum(tre)&&judgeRed(tre))printf("Yes\n");
        else printf("No\n");
    }
}

猜你喜欢

转载自blog.csdn.net/Puppettt/article/details/82144767