1135 Is It A Red-Black Tree (30 分)

版权声明:如有错误,请指出,不胜感激。 https://blog.csdn.net/qq_36424540/article/details/84310291

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpg rbf2.jpg rbf3.jpg
Figure 1 Figure 2 Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

  看到 只给了我们先序序列直接蒙了,其实树还有一个性质,就是左小右大。

这样我们就可以区分出来左右子树了。

#include<bits/stdc++.h>
using namespace std;

typedef long long LL;
#define rep(i,a,b) for(int i=a;i<b;++i)
#define bug(x) printf("**x:%d\n",x)

const int N=310;
int arr[N];

map<int,int> col,ID;

vector<int> vec[N];

void get_tr(int* arr,int len)
{
    if(len<=1)return;

    int i=0;
    for(; i<len; i++) {
        if(arr[i]>arr[0])break;
    }
    int f=arr[0],u=arr[1],v=arr[i];

    if(arr[1]<arr[0]) {
        vec[ID[f]].push_back(u);
        get_tr(arr+1,i-1);
    }
    if(i<len) {
        vec[ID[f]].push_back(v);
        get_tr(arr+i,len-i);
    }
}

int dfs(int u,int f)
{
    //printf("u:%d f:%d %d\n",u,f,ID[u]);
    int t=ID[u];
    int sz=vec[t].size();
    if(sz==0) {
        return col[u]==1?2:1;
    }
    int num=-1;
    for(int i=0; i<sz; i++) {
        int v=vec[t][i];
        if(col[u]==-1&&col[v]==-1)return -1;
        //printf(" v:%d\n",v);
        int tmp=dfs(v,u);
        //printf(" tmp:%d\n",tmp);
        if(tmp==-1)return -1;
        if(num==-1)num=tmp;
        if(num!=tmp)return -1;
    }
    if(sz==1&&num!=1)return -1;
    return num+max(col[u],0);
}


int tt[N];
void init()
{
    ID.clear();
    col.clear();
    rep(i,0,N)vec[i].clear();
}

int main()
{
    int T;
    while(scanf("%d",&T)==1) {
        rep(kase,0,T) {
            init();
            int n;
            scanf("%d",&n);
            rep(i,1,n+1) {
                scanf("%d",&arr[i]);
                col[abs(arr[i])]=(arr[i]>0?1:-1);
                arr[i]=tt[i]=abs(arr[i]);
            }
            sort(tt+1,tt+n+1);
            rep(i,1,n+1) {
                ID[tt[i]]=i;
            }
            get_tr(arr+1,n);
            int f=dfs(arr[1],-1);
            if(col[arr[1]]<0)f=-1;
            if(f!=-1)printf("Yes\n");
            else printf("No\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36424540/article/details/84310291