River Hopscotch

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn  = 5e4+10;

int val[maxn],dif[maxn];

int L,N,M;
/*
想尽了数据结构,但是还是没能想出来
这道题就是属于那种我们能做出来,但是对已有的知识点有点不自信,或者对自己的思维不自信
二分就适合于这种模拟但是有条件的模拟,直接来找到一个答案可能比较难受,
但是利用单调性和二分就能快速的找到我们的答案
*/

int check(int x,int m){
    int ans=0,cur=0;
    for(int i=1;i<=N+1;i++){
        cur+=dif[i];
        if(cur<x)
            ans++;
        else
            cur=0;
    }
   // printf("x:%d ans:%d m:%d\n",x,ans,m);
    return ans<=m;
}

int main()
{
    scanf("%d %d %d",&L,&N,&M);
    for(int i=1;i<=N;i++){
        scanf("%d",&val[i]);
    }
    sort(val+1,val+N+1);
    for(int i=1;i<=N;i++){
        dif[i]=val[i]-val[i-1];
    }
    dif[N+1]=L-val[N];
    int l=0,r=L,mid,ans;
    while(l<=r){
        mid=(l+r)/2;
        if(check(mid,M)){
            ans=mid;
            l=mid+1;
        }
        else
            r=mid-1;
    }
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36424540/article/details/80308844