ACM刷题之POJ————River Hopscotch

版权声明:本文为小时的枫原创文章,未经博主允许不得转载。 https://blog.csdn.net/xiaofeng187/article/details/79981253
River Hopscotch
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 17988   Accepted: 7516

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).


一道二分的题目

一般题目让你求什么,就二分什么,这里求距离,就二分距离。

这里的输入数据是无序的,记得排序。

统计节点的距离小于二分值的个数,然后比较就好了。

注意一点,删除后,那个节点前后距离都会改变,不能单单计算前面减后面的距离来计数。


这里给两个样例:

10 0 0 

0


10 1 1

6

10


下面是ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<string>
#include<iostream>
using namespace std;
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int N=2e5+7;

int i, j, le, n , m; 
int a[N];

bool check(int mi) {
	int cnt = 0, before = 0;
	for (i = 1 ; i <= n; i ++) {
		if (a[i] - a[before] <= mi) {
			++cnt;
		} else {
			before = i;
		}
	}
	if (cnt > m) {
		return true;
	} else return false;
}

int main()
{
	//freopen("f:/input.txt", "r", stdin);
	while(cin>>le>>n>>m) {
		int maxn = -INF;
		a[0] = 0;
		for (i = 1; i <= n; i ++) {
			cin>>a[i];
			if (a[i] > maxn) maxn = a[i];
		}
		a[++n] = le; 
		sort(a, a + n);
		int l = 0, r = le * 2, mid;
		while (l < r) {
			mid = MID(l, r);
			if (check(mid)) {
				r = mid;
			} else {
				l = mid + 1;
			}
		}
//		if (l == le) --l;
		cout<<l<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/xiaofeng187/article/details/79981253