D - River Hopscotch POJ - 3258 (二分专题)。

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, Lunits away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

扫描二维码关注公众号,回复: 2567024 查看本文章

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意:有L长的河河中间有n个石头拿走了m个石头让拿走石头后的最小距离最大化 (二分的最大值)
把拿走石头后的最小距离进行二分

以0和最远点石头距离为两端点

然后进行比较。当那个距离左走的最小石头数和n-m个相同时就是满足的

#include<cstdio>
#include<algorithm>
using namespace std;
int L,n,m;
int num[50055];
bool jugde(int mid)    //bool类型的函数还可以这样子写哈哈哈 
{
    int t=0;//现在所在的位置 
    int sum=0;
    for(int i=0;i<n;i++){
        if(num[i]-t<mid)   continue; //如果这个位置的距离大于两个石头之间的距离直接跳过去 
        else
		{                              //否则所剩的石头数加一现在的距离变为所在的位置 
            sum++;
			t=num[i];
            if(L-num[i]<mid) break; //到岸上的距离也小于mid就直接上岸 
		}
    }
    return sum>=n-m;//石头剩的多了距离取小了 
}
int main()
{
    while(scanf("%d %d %d",&L,&n,&m)!=EOF)
	{
        for(int i=0;i<n;i++)
            scanf("%d",&num[i]);
        sort(num,num+n);
        int l=0;
        int r=L;
        int ans=0;
        while(l<=r)
		{
            int mid=(l+r)/2;//二分牛每次走的最小距离 
            if(jugde(mid))
			{
                ans=mid;
                l=mid+1;
            }
            else r=mid-1;
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42079027/article/details/81264891