蓝桥杯 提高题 Minesweeper

蓝桥杯 提高题 Minesweeper

题目描述

Minesweeper Have you ever played Minesweeper? This cute little game comes with a certain operating system whose name we can’t remember. The goal of the game is to find where all the mines are located within a M x N field. The game shows a number in a square which tells you how many mines there are adjacent to that square. Each square has at most eight adjacent squares. The 4 x 4 field on the left contains two mines, each represented by a '*' character. If we represent the same field by the hint numbers described above, we end up with the field on the right: . . . . . . . . . . . . . . 10022101 101110 *... .... .*.. .... *100 2210 1*10 1110

输入

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m ( 0 < n , m 100 ) ( 0 < n, m\leq100) which stand for the number of lines and columns of the field, respectively. Each of the next n lines contains exactly m characters, representing the field. Safe squares are denoted by . '.' and mine squares by '*' both without the quotes. The first field line where n = m = 0 represents the end of input and should not be processed.

输出

For each field, print the message Field #x: on a line alone, where x stands for the number of the field starting from 1. The next n lines should contain the field with the ``.’’ characters replaced by the number of mines adjacent to that square. There must be an empty line between field outputs.

样例输入

4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

样例输出

Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100

简单BFS,注意输出格式即可:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
char s[100][100];
int num[100][100],n,m;
int step[8][2]={0,1, 0,-1, 1,0 ,-1,0, 1,1, -1,1, 1,-1, -1,-1};

void bfs(int x,int y){
    int xx,yy;
    for(int i=0;i<8;i++){
        xx=x+step[i][0];
        yy=y+step[i][1];
        if(xx>=0 && xx<4 && yy>=0 && yy<4 && s[xx][yy]!='*') num[xx][yy]++;
    }
}

int main() {
    int id=0;
    while(cin>>n>>m){
        id++;
        if(n==0 && m==0) break;
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                cin>>s[i][j];
            }
        }
        fill(num[0],num[0]+100*100,0);
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(s[i][j]=='*') bfs(i,j);
            }
        }
        printf("Field #%d:\n",id);
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(s[i][j]=='*') cout<<"*";
                else cout<<num[i][j];
            }
            puts("");
        }
        puts("");
    }
}
发布了288 篇原创文章 · 获赞 14 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_43765333/article/details/104343779
今日推荐