dp 例9-1 A Spy in the Metro UVA - 1025

Description

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated.

Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria.

The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.

\epsfbox{p2728.eps}
Input
The input file contains several test cases. Each test case consists of seven lines with information as follows.
Line 1.
The integer N ( 2N50), which is the number of stations.
Line 2.
The integer T ( 0T200), which is the time of the appointment.
Line 3.
N - 1 integers: t1, t2,..., tN - 1 ( 1ti70), representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2 the time between the second and the third station, and so on.
Line 4.
The integer M1 ( 1M150), representing the number of trains departing from the first station.
Line 5.
M1 integers: d1, d2,..., dM1 ( 0di250 and di < di + 1), representing the times at which trains depart from the first station.
Line 6.
The integer M2 ( 1M250), representing the number of trains departing from the N-th station.
Line 7.
M2 integers: e1, e2,..., eM2 ( 0ei250 and ei < ei + 1) representing the times at which trains depart from the N-th station.
The last case is followed by a line containing a single zero.

Output
For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ` impossible' in case Maria is unable to make the appointment. Use the format of the sample output.


Sample Input


4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0


Sample Output


Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

dp[i][j] 表示 在时刻i 车站j 最少需要等待多长时间

如果在 i时刻 j车站 能够上车 ,则dp[i][j]=min{dp[i+乘车时间][ 下一站]}

需要未来时间dp结果  则从后往前遍历

#include<bits/stdc++.h>
using namespace std;
int n,T;
int t[100];
int m1,m2;
int d[100],e[100];
int N=0;
int dp[250][55];//i时刻后碰面 在j站台还需要等多长时间		 
int tag[250][55][2]; 
int main()
{
	while(1)
	{	
		cin>>n;
		N++;
		if(n==0) break;
		scanf("%d",&T);
		for(int i=1;i<n;i++)
		{
			scanf("%d",&t[i]);
		}
		scanf("%d",&m1);
		for(int i=0;i<m1;i++)
		{
			scanf("%d",&d[i]);//右 
		}
		scanf("%d",&m2);
		for(int i=0;i<m2;i++)
		{
			scanf("%d",&e[i]);//左 
		}
		
		//初始化
		for(int i=0;i<=T;i++) 
		{
			for(int j=1;j<=n;j++)
			{
				dp[i][j]=1e9;
			}
		}
		for(int i=0;i<=T;i++)
		{
			for(int j=1;j<=n;j++)
			{
				tag[i][j][0]=0;
				tag[i][j][1]=0;
			}
		}
		
		int sum=0;
		for(int i=1;i<n;i++)
		{
			for(int j=0;j<m1;j++)
			{
				tag[sum+d[j]][i][0]=1; //tag[i][j][0] i时刻 j 车站有向右的车 
			}
			sum+=t[i];
		}
		
		sum=0;
		for(int i=n-1;i>=1;i--)
		{
			for(int j=0;j<m2;j++)
			{
				tag[sum+e[j]][i+1][1]=1;//tag[i][j][1] i时刻 j 车站有向左的车
			}
			sum+=t[i];
		}
		
		
		for(int i=1;i<n;i++) dp[T][i]=1e9;
		dp[T][n]=0;//!!临界初始化 
		
		for(int i=T-1;i>=0;i--)//枚举时间   从后往前 
		{
			for(int j=1;j<=n;j++)//枚举此刻在哪个车站 
			{
				dp[i][j]=dp[i+1][j]+1;//默认加一
				if(tag[i][j][0]&&i+t[j]<=T&&j+1<=n) //向右 
					dp[i][j]=min(dp[i][j],dp[i+t[j]][j+1]);
				if(tag[i][j][1]&&i+t[j-1]<=T&&j-1>=1) //向左 
					dp[i][j]=min(dp[i][j],dp[i+t[j-1]][j-1]);
			}
		}
		printf("Case Number %d: ",N);
		if(dp[0][1]<1e9)printf("%d\n",dp[0][1]);
		else printf("impossible\n");
	}
	

	
}

发布了44 篇原创文章 · 获赞 6 · 访问量 1175

猜你喜欢

转载自blog.csdn.net/qq_43868883/article/details/103947285
今日推荐