A Spy in the Metro UVA - 1025(DP)

https://cn.vjudge.net/problem/UVA-1025

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated. Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria. The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.

Input

The input file contains several test cases. Each test case consists of seven lines with information as follows. Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations. Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment. Line 3. N − 1 integers: t1, t2, . . . , tN−1 (1 ≤ ti ≤ 20), representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2 the time between the second and the third station, and so on. Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first station. Line 5. M1 integers: d1, d2, . . . , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which trains depart from the first station. Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th station. Line 7. M2 integers: e1, e2, . . . , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which trains depart from the N-th station. The last case is followed by a line containing a single zero.

Output

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is unable to make the appointment. Use the format of the sample output.
 

Sample Input

4 

55 

5 10 15 

4

0 5 10 20 

4 

0 5 10 15 

4 

18 

1 2 3 

5 

0 3 6 10 12 

6 

0 3 5 7 12 15 

2

30 

20 

1 

20 

7 

1 3 5 7 11 13 17 

0 

Sample Output

Case Number 1: 5 

Case Number 2: 0 

Case Number 3: impossible

这个题有个梗,就是题目本身不太对,具体看代码。

这个题说的是,

第一行:一个直线的铁路上有N个站点;

第二行:给出总时间T;(这个人可以等一分钟,可以上车, 最后T时间的时候在第N个站点。)

第三行:从第一个站点到第二个站点之间需要的时间,第二个到第三个时间的时间,依此类推。。。

第四行:从左到右一共有M1个火车;

第五行:这M1个火车出发的时间;

第六行:从右到左一共有M2个火车:

第七行:这M2个火车出发的时间;

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
const int MAX = 0x3f3f3f3f;
int t[60], dp[220][60];//在站点等的时间。
bool h[220][60][2];//这个三维数组必须放在后面,不然就不对,不知道为啥,
//某一时刻在某一站点有向左或者向右的火车。
int main()
{
    int T, N, M1, M2, cas = 1, x;
    while(~scanf("%d", &N) && N)
    {
        scanf("%d", &T);
        memset(h, 0, sizeof(h));
        memset(t, 0, sizeof(t));
        memset(dp, 0, sizeof(dp));
        for(int i=1; i<=N-1; i++)//如果T时刻不在N站点,就无法到达了,,,
            dp[T][i] = MAX;
        dp[T][N] = 0;//用逆向思维,到过来看,T时刻在N点开始,即为0;
        for(int i=1; i<N; i++)
        {
            scanf("%d", &t[i]);//记下站点之间需要的时间。
        }
        scanf("%d", &M1);
        for(int i=1; i<=M1; i++)
        {
            scanf("%d", &x);//记下出发时的时间,
            for(int j=1; j<=N; j++)
            {
                h[x][j][0] = 1;//便可依次标记出某个时间在某个站点有没有火车。
                x = x + t[j];
            }
        }
        scanf("%d", &M2);
        for(int i=1; i<=M2; i++)
        {
            scanf("%d", &x);
            for(int j=N; j>=1; j--)//跟上面一样。
            {
                h[x][j][1] = 1;
                x = x + t[j-1];
            }
        }
        for(int i=T-1; i>=0; i--)
        {
            for(int j=1; j<=N; j++)
            {
                dp[i][j] = dp[i+1][j] + 1;//第一个状态,等着,
                if(j<N && i+t[j]<=T && h[i][j][0]==1)//如果有向右的车,比较一下,记录最短时间,j<N是因为到N点时不能向右移动了。
                    dp[i][j] = min(dp[i][j], dp[i+t[j]][j+1]);
                if(j>1 && i+t[j-1]<=T && h[i][j][1]==1)////如果有向左的车,比较一下,记录最短时间,j>1是因为到第一个点时不能向左移动了。
                    dp[i][j] = min(dp[i][j], dp[i+t[j-1]][j-1]);
            }
        }
        printf("Case Number %d: ", cas++);
        if(dp[0][1]>=MAX)
            printf("impossible\n");
        else
            printf("%d\n", dp[0][1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42137874/article/details/82866675
今日推荐