POJ1013解题报告

问题描述:

Counterfeit Dollar
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 48963
Accepted: 15461

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

解题思路:

本题的问题描述为,有12个硬币,其中一枚硬币是假币,不知轻重。与常规的智力题不同的是,这里是给出了三次称量的结果,每次分别为:左天平硬币标号-右天平硬币标号-称量结果。根据这个结果,要求你找出假币并判断出假币比真币轻还是重。

这个问题很简单,硬币一共只有12枚,结果也只有两种,要么比真币轻,要么比真币重,那么一共最多只有12*2=24种情况,我们进行枚举,一一试探,看是否符合输入的条件即可


代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<string.h>
using namespace std;
char Right[3][7];
char Left[3][7];
char Result[3][7];
bool IsFake(char c,bool light);

int main()
{
	int t; 
	cin>>t;
	while(t--)
	{
		for(int i=0;i<3;i++)
		{
			cin>>Left[i]>>Right[i]>>Result[i];
		}
		for(char c='A';c<='L';c++)
		{
			if(IsFake(c,true))
			{
				cout<<c<<" is the counterfeit coin and it is light. "<<endl;
				break;
			}
			else if(IsFake(c,false))
			{
				cout<<c<<" is the counterfeit coin and it is heavy. "<<endl;
				break;
			}
		}
	}
	return 0;
}

bool IsFake(char c,bool light)
{
	char *pleft,*pright,*presult;
	for(int i=0;i<3;i++)
	{
		if(light)
		{
			pleft=Left[i];
			pright=Right[i];
		}
		else
		{
			pleft=Right[i];
			pright=Left[i];
		}
		switch(Result[i][0])
		{
			case 'u':if(strchr(pright,c)==NULL)
						return false;
					break;
			case 'e':if(strchr(pleft,c) || strchr(pright,c))
						return false;
					break;
			case 'd':if(strchr(pleft,c)==NULL)
						return false;
					break;
		}
	}
	return true;
}

猜你喜欢

转载自blog.csdn.net/qq_33657357/article/details/79597018