poj 1742 Coins(多重背包和二进制优化)

题目戳这里=-=
Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 48420 Accepted: 16282
Description

People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output

For each test case output the answer on a single line.
Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output

8
4
Source

LouTiancheng@POJ

题目大意:用给定的硬币可以表示给定的范围类有多少个数。
题解:普通的多重背包用二进制优化即可,如果给定的硬币面值和张数的乘积大于给定的范围就直接完全背包就好了。

下面就是代码啦

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <stack>
using namespace std;
const int maxn = 1e5+100;
const int inf = 0x3f3f3f3f;
const int mod = 10000;
typedef long long ll;
int n,m;
int s[250],c[250];
int dp[maxn];
inline int read()
{
    int x=0;char ch=getchar();
    while(ch<'0'||ch>'9')ch=getchar();
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x;
}
int main()
{
    while(~scanf("%d %d",&n,&m)){
        if(n==m&&m==0)break;
        for(int i=1;i<=n;i++){
            s[i]=read();
        }
        for(int i=1;i<=n;i++){
            c[i]=read();
        }
        memset(dp,-inf,sizeof(dp));
        dp[0]=0;
        for(int i=1;i<=n;i++){
            if(c[i]*s[i]<m){
                int num=c[i];
                for(int k=1;num>0;k<<=1){
                    if(k>num)k=num;
                    num-=k;
                    for(int j=m;j>=s[i]*k;j--){
                        if(dp[j-s[i]*k]+s[i]*k>dp[j]) //这里绝对不能用max函数用了就是超时,我的一个下午就在这个上面了。
                            dp[j]=dp[j-s[i]*k]+s[i]*k;
                    }
                }
            }
            else{
                for(int j=s[i];j<=m;j++){
                    if(dp[j-s[i]]+s[i]>dp[j]){
                        dp[j]=dp[j-s[i]]+s[i];
                    }
                }
            }
        }
        int ans=0;
        for(int i=1;i<=m;i++){
            if(dp[i]>0){
                //cout<<i<<' '<<dp[i]<<endl;
                ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
发布了35 篇原创文章 · 获赞 25 · 访问量 826

猜你喜欢

转载自blog.csdn.net/qq_43816599/article/details/100176567