1139 First Contact (30分)

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0
#include<iostream>
#include<unordered_set>
#include<set>
#include<vector>
#include<unordered_map>
#include<cmath>
#include<algorithm>
using namespace std;
struct result{
    
    int c;
    int d;

};
bool cmp(result a, result b){

    return a.c != b.c ? a.c < b.c : a.d < b.d;

}
int main(){
    int n, m;
    cin >> n >> m;
    unordered_map<string, unordered_set<string> > relations;
    
    for(int i = 0; i < m; i++){
        string s_a, s_b;
        cin >> s_a >> s_b;

        // int temp_a, temp_b;
        // scanf("%d %d", &temp_a, &temp_b);
        // relations[temp_a].insert(temp_b);
        // relations[temp_b].insert(temp_a);
        relations[s_a].insert(s_b);
        relations[s_b].insert(s_a);

    }

    int k;
    cin >> k;
    for(int i = 0; i < k; i++){
        // int temp_a, temp_b;
        // scanf("%d %d", &temp_a, &temp_b);
        string s_a, s_b;
        cin >> s_a >> s_b;
        vector<result> vec;
        for(auto it_1 : relations[s_a]){

            if(it_1.length() == s_a.length()){
                for(auto it_2 : relations[s_b]){


                    if(relations[it_1].find(it_2) != relations[it_1].end() && it_2.length() == s_b.length()){
                        
                        if(it_1 != s_b && it_2 != s_a){ //找同性朋友时避免找到伴侣
                            
                            result temp;

                            temp.c = abs(stoi(it_1));
                            temp.d = abs(stoi(it_2));
                            vec.push_back(temp);


                        }
                        
                        
                        
                    }

                }
            }
            

        }
        printf("%d\n", int(vec.size()));
        sort(vec.begin(), vec.end(), cmp);
        for(int i = 0; i < vec.size(); i++){

            printf("%04d %04d\n", vec[i].c, vec[i].d);

        }

    }

    // for(auto i : relations){
    //     cout << i.first << "++++" << endl;
    //     cout << endl;
    //     for(auto j : i.second){

    //         cout << j << " ";
    //     }
    //     cout << endl;
    //     cout << endl;
    // }
    return 0;
}
发布了38 篇原创文章 · 获赞 0 · 访问量 529

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104085760