PAT 甲级 1139 First Contact

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/87988853

1139 First Contact (30 point(s))

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

经验总结:

emmm  刚开始思路走错了,想用DFS+map解决问题,然而实际并不能,因为题目里有可能出现-0这种情况,这时候利用map解决就十分繁琐了,向柳神学习了代码,不得不说,大神就是大神。
学会了这么几个东西,看到编号为四位,就不要想着用二维数组存储了,可以A*10000+B,利用map,当然,也可以使用map+反向map存储,但是比较麻烦。
需要注意,两个人性别相同时,如果这两个人也是朋友,那么就需要把这种情况排除。
处理-0这种情况,肯定不能按照整型读入,因为一旦读入,0就失去了负号,所以按照字符串长度进行处理是很巧妙的。
就这么些啦~

AC代码

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <unordered_map>
using namespace std;
const int maxn=10010;
int n,m,a,b,k;
unordered_map<int,bool> mp;
vector<int> adj[maxn];
vector<pair<int,int> >ans;
bool cmp(pair<int,int> x,pair<int,int> y)
{
	if(x.first!=y.first)
		return x.first<y.first;
	return x.second<y.second;
}
	
int main()
{
	
	int num=0;
	char s1[6],s2[6];
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;++i)
	{
		scanf("%s%s",s1,s2);
		int len1=strlen(s1);
		int len2=strlen(s2);
		sscanf(s1,"%d",&a);
		sscanf(s2,"%d",&b);
		a=abs(a);
		b=abs(b);
		if(len1==len2)
		{
			adj[a].push_back(b);
			adj[b].push_back(a);
		}
		mp[a*10000+b]=mp[b*10000+a]=true;
	}
	scanf("%d",&k);
	for(int i=0;i<k;++i)
	{
		scanf("%s%s",s1,s2);
		int len1=strlen(s1);
		int len2=strlen(s2);
		sscanf(s1,"%d",&a);
		sscanf(s2,"%d",&b);
		ans.clear();
		a=abs(a);
		b=abs(b);
		for(int j=0;j<adj[a].size();++j)
			for(int k=0;k<adj[b].size();++k)
			{
				if(adj[a][j]==b||adj[b][k]==a)
					continue;
				if(mp[adj[a][j]*10000+adj[b][k]]==true)
					ans.push_back(make_pair(adj[a][j],adj[b][k]));
			}
		printf("%d\n",ans.size());
		sort(ans.begin(),ans.end(),cmp);
		for(int j=0;j<ans.size();++j)
			printf("%04d %04d\n",ans[j].first,ans[j].second);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/87988853