#1139. First Contact【图论 + 模拟】

原题链接

Problem Description:

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N N N ( 1 < N ≤ 300 1 < N \leq 300 1<N300) and M M M, being the total number of people and the number of friendship relations, respectively. Then M M M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K K K ( ≤ 100 \leq 100 100) is given, which is the number of queries. Then K K K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

Problem Analysis:

一道关于图论的模拟题,关于找到符合条件的关系,直接两层循环遍历即可,麻烦点在于处理编号等其他问题上,详细细节见代码。

Code

#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#include <unordered_map>

using namespace std;

const int N = 310;

int n, m;
unordered_map<string, int> mp; // 将所有人的编号做一个映射
string num[N];
int id; // 所有人的编号
bool g[N][N]; // 邻接矩阵存关系
vector<int> boys, girls; // 将所有的男孩女孩分别存储到不同的容器中

int main()
{
    
    
    scanf("%d%d", &n, &m);
    char as[N], bs[N];

    while (m -- )
    {
    
    
        string a, b;
        scanf("%s%s", as, bs); // 首先读入朋友关系,双向边,每个人的编号数字较大,但总人数只有300,需要无序离散化一下
        a = as, b = bs; // as,bs当成中间变量,用于加快读入

        string x = a, y = b;
        if (x.size() == 5) x = x.substr(1);
        if (y.size() == 5) y = y.substr(1);
        if (mp.count(x) == 0) mp[x] = ++ id, num[id] = x; // 无序离散化, num[id] 表示存储的逆映射
        if (mp.count(y) == 0) mp[y] = ++ id, num[id] = y;
    
        int px = mp[x], py = mp[y];
        g[px][py] = g[py][px] = true;
        
        if (a[0] != '-') boys.push_back(px);
        else girls.push_back(px);
        if (b[0] != '-') boys.push_back(py);
        else girls.push_back(py);
    }
    
    // 去重 ---
    sort(boys.begin(), boys.end());
    boys.erase(unique(boys.begin(), boys.end()), boys.end());
    sort(girls.begin(), girls.end());
    girls.erase(unique(girls.begin(), girls.end()), girls.end());    
    // 去重 ---
    
    int k;
    scanf("%d", &k);
    
    while (k -- )
    {
    
    
        vector<pair<string, string>> res; // 存储答案,一对朋友关系
        string x, y;
        scanf("%s%s", as, bs);
        x = as, y = bs;
        
        vector<int> p = boys, q = boys; // 一开始并不知道两个人的性别,先这样赋值
        if (x[0] == '-') p = girls, x = x.substr(1); 
        if (y[0] == '-') q = girls, y = y.substr(1);
    
        int a = mp[x], b = mp[y];
        
        for (int c : p)
            for (int d : q)
            {
    
    
                if (c != a && c != b && d != a && d != b && g[a][c] && g[c][d] && g[d][b])
                    res.push_back({
    
    num[c], num[d]});
            }
                     
        sort(res.begin(), res.end());
        printf("%d\n", res.size());
        
        for (auto p : res) 
            printf("%s %s\n", p.first.c_str(), p.second.c_str());
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121084446