PAT (Advanced Level) Practice 1139 First Contact (30分) (unordered_map用来标记+哈希)

1.题目

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

2.题目分析

vector中只记录ID,不记录正负,而在标记时使用了哈希,避免了负数难以记录的问题

一个人只有一个性别的理解:所有的数据中不会同时出现1001,-1001 

3.代码

参考柳神(https://blog.csdn.net/liuchuo/article/details/79065004

//带查看
#include<iostream>
#include<unordered_map>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
	int id1;
	int id2;
};
	bool cmp(const node &x,const node &y)
	{
		if (x.id1 == y.id1)return x.id2 < y.id2;
		return x.id1 < y.id1;
	}

vector<int>f[10010];
unordered_map<int, bool>mark;
int main()
{
	int n, m,k;
	scanf("%d %d", &n, &m);
	for (int i = 0; i < m; i++)
	{
		string a, b;
		cin >> a >> b;
		if (a.length() == b.length())
		{
			f[abs(stoi(a))].push_back(abs(stoi(b)));
			f[abs(stoi(b))].push_back(abs(stoi(a)));
		}
		mark[abs(stoi(a)) * 10000 + abs(stoi(b))] = mark[abs(stoi(b)) * 10000 + abs(stoi(a))] = true;
	}
	scanf("%d", &k);
	for (int i = 0; i < k; i++)
	{
		int  a, b;
		cin >> a >> b;
		vector<node>output;	
		for (int j = 0; j < f[abs(a)].size(); j++)
		{
			for (int s = 0; s < f[abs(b)].size(); s++)
			{
				if (f[abs(a)][j] == abs(b) || f[abs(b)][s] == abs(a))continue;
				if (mark[f[abs(a)][j] * 10000 + f[abs(b)][s]] == true)
					output.push_back(node{ f[abs(a)][j],f[abs(b)][s] });
			}
		}
		sort(output.begin(), output.end(), cmp);
		printf("%d\n", output.size());
		for (int j = 0; j < output.size(); j++)
			printf("%04d %04d\n", output[j].id1, output[j].id2);
	}
	
}
发布了204 篇原创文章 · 获赞 4 · 访问量 5689

猜你喜欢

转载自blog.csdn.net/qq_42325947/article/details/105104477