PAT A1139 First Contact (30point(s))

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0
  • 思路 1:md,做的烦死了 / (> /\ <)
    开始用DFS做了半天,发现很多问题,遂弃之
    改用暴力枚举
    首先,要解决图的下标:女生为负数,要转化为正数,Change():用两个map,一个map:将 男生id 直接映射为 idex,女生 id 映射为 n + idex;另一个map,用于查询反向查询原id(转化为正数)

输入时,标记用二维数组标记每条边,同时将每个人的同性朋友push进自己的vector[id]

查询:qa, qb, 遍历qa, qb 的所有同学朋友qa_f , qb_f,如果qa_f 与 qb_f是朋友,鹊桥搭建完成!将这个桥push进结果数组(Ps. 因为结果需排队,故用一个结构体pair 的数组)

  • 坑点:
  1. Wrong 1:样例 3 4 5 : a,b互为朋友的情况要排除
  2. Wrong 2: 样例 2: +0000 与 -0000 ,如果用int存会全变成0,无法区分性别,故应改为string输入id
  • code:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 500, maxn2 = 1000;
int G[maxn2][maxn2];
struct Friend{
	int first, second;
};

vector<int> same[maxn];

int idex = 0;
unordered_map<string, int> mp1;
unordered_map<int, int> mp2;

int Change(string s, int n){
	if(mp1.find(s) == mp1.end()){
		mp1[s] = s[0] == '-' ? n + idex : idex;
		mp2[mp1[s]] = abs(stoi(s));
		idex++; 
	}
	return mp1[s];	
}
bool cmp(Friend a, Friend b){
	return a.first != b.first ? a.first < b.first : a.second < b.second;
}
vector<Friend> ans;
void GetFriend(int a, int b){
	for(int i = 0; i < same[a].size(); ++i){
		for(int j = 0; j < same[b].size(); ++j){
			int af = same[a][i], bf = same[b][j];
//			if(a == bf || b == af) continue; 	//Wrong 1 : 样例 3 4 5 
			if(a != bf && b != af && G[af][bf] == 1){
				ans.push_back(Friend{mp2[af], mp2[bf]});
			}
		}
	}
}
int main(){
	int n, m;
	scanf("%d %d", &n, &m);
	for(int i = 0; i < m; ++i){
		string p1, p2;
		cin >> p1 >> p2;	//Wrong 2: +0000 / -0000 
		int tp1 = Change(p1, n), tp2 = Change(p2, n);
		G[tp1][tp2] = G[tp2][tp1] = 1;
		if(p1.size() == p2.size()){
			same[tp1].push_back(tp2);
			same[tp2].push_back(tp1);
		}
	}
	int q;
	scanf("%d", &q);
	for(int i = 0; i < q; ++i){
		string q1, q2;
		cin >> q1 >> q2;
		int tq1 = mp1[q1], tq2 = mp1[q2];
		ans.clear();
		GetFriend(tq1, tq2);
		sort(ans.begin(), ans.end(), cmp);
		printf("%d\n", ans.size());
		for(int j = 0; j < ans.size(); ++j){
			printf("%04d %04d\n", ans[j].first, ans[j].second);
		}
	}
	return 0;
}
发布了271 篇原创文章 · 获赞 5 · 访问量 6513

猜你喜欢

转载自blog.csdn.net/qq_42347617/article/details/104234079