HDU1083Courses(模板题)

Problem Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:

 

Sample Input

 

2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1

 

Sample Output

 

YES NO

题意:是否满足给每个科目分配的课代表的同时,课代表们只代表一个科目

        二分图最大匹配

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int n,p;
int a[310][310];
int pre[310];//记录所匹配的点 
bool vis[310];//是否访问过 
int dfs(int l){
	for(int i=1;i<=n;i++){
		if(a[l][i]==1 && vis[i]==0){//保证每次子访问一次 
			vis[i]=1;
			if(pre[i]==-1 || dfs(pre[i])){
				pre[i]=l;
				return 1;
			}
		}
	}
	return 0;
}
int main(){
	int l,r;
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%d %d",&p,&n);
		memset(a,0,sizeof(a));
		int b,c;
		for(int i=1;i<=p;i++){
			scanf("%d",&b);
			for(int j=1;j<=b;j++){
				scanf("%d",&c);
				a[i][c]=1;
			}
		}
		memset(pre,-1,sizeof(pre));
		int sum=0;
		for(int i=1;i<=p;i++){
			memset(vis,0,sizeof(vis));
			if(dfs(i)){
				sum++;
			}
		}
		if(sum==p)
			printf("YES\n");
		else
			printf("NO\n");
	}
} 

猜你喜欢

转载自blog.csdn.net/doublekillyeye/article/details/81391274