1086 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

#include "iostream"

#include "string"

#include "string.h"

#include "stack"

using namespace std;

struct node{

int data;

node* lchild;

node* rchild;

};

const int maxn=50;

int n;

int pre[maxn];

int in[maxn];

node* create(int preL,int preR,int inL,int inR){

if (preL>preR) {

return NULL;

}

node* root=new node;

root->data=pre[preL];

int k;

for (k=inL; k<inR; k++) {

if (in[k]==root->data) {

break;

}

}

int num=k-inL;

root->lchild=create(preL+1, preL+num, inL, k-1);

root->rchild=create(preL+num+1, preR, k+1, inR);

return root;

}

int number=0;

void POT(node* root){

if (root->lchild!=NULL) {

POT(root->lchild);

}

if (root->rchild!=NULL) {

POT(root->rchild);

}

printf("%d",root->data);

number++;

if (number<n) {

printf(" ");

}

}


 

int main(){

scanf("%d",&n);

char s[5];

stack<int> temp;

int x=0,preIndex=0,inIndex=0;

for (int i=0; i<n*2; i++) {

scanf("%s",s);

if (strcmp(s,"Push")==0) {

scanf("%d",&x);

pre[preIndex++]=x;

temp.push(x);

}

else{

in[inIndex++]=temp.top();

temp.pop();

}

}

node* root=create(0, n-1, 0, n-1);

POT(root);

}


 

发布了14 篇原创文章 · 获赞 0 · 访问量 137

猜你喜欢

转载自blog.csdn.net/Yanhaoming1999/article/details/104081927
今日推荐