1086 Tree Traversals Again (25point(s))

1086 Tree Traversals Again (25point(s))

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

#include<bits/stdc++.h>
using namespace std;
const int maxn=35;
struct node{
    
    
    int data;
    node *lchild,*rchild;
};
int pre[maxn],in[maxn];
node* create(int preL,int preR,int inL,int inR){
    
    
    if(preL>preR) return NULL;
    node* root=new node;
    root->data=pre[preL];
    int k;
    for(k=inL;k<=inR;++k)
        if(in[k]==pre[preL]) break;
    int numLeft=k-inL;
    root->lchild=create(preL+1,preL+numLeft,inL,k-1);
    root->rchild=create(preL+numLeft+1,preR,k+1,inR);
    return root;
}
int num=0;
void postOrder(node *root){
    
    
    if(!root) return;
    postOrder(root->lchild);
    postOrder(root->rchild);
    if(num!=0) printf(" ");
    num++;
    printf("%d",root->data);
}
int main(){
    
    
    int n;
    scanf("%d",&n);
    stack<int> s;
    int j=0,k=0;
    string str;
    int index;
    for(int i=0;i<2*n;++i){
    
    
        cin>>str;
        if(str=="Push"){
    
    
            scanf("%d",&index);
            pre[j++]=index;
            s.push(index);
        }else{
    
    
            in[k++]=s.top();
            s.pop();
        }
    }
    node* root=create(0,n-1,0,n-1);
    postOrder(root);
}

猜你喜欢

转载自blog.csdn.net/weixin_44970602/article/details/112077876