1086 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1
#include<cstdio>
#include<iostream>
#include<string>
#include<stack>
using namespace std;

int in[30] = {0},pre[30] = {0};
bool flag = true;
void postorder(int root,int start,int end){
	if(start>end)
		return;
	int i = start;
	while(i<end && in[i] != pre[root] ) i++;
	postorder(root+1,start,i-1);
	postorder(root+1+i-start,i+1,end);
	printf("%s%d",flag==true?"":" ",pre[root]);
	flag = false;
}

int main(){
	stack<int> s; 
	int n,root,a,j=0,k=0;
	string str;
	cin>>n;
	for(int i=0;i<2*n;i++){
		cin>>str;
		if(str.length()==4){
			cin>>a;
			s.push(a);
			pre[k++] = a;
		}else{
			in[j++] = s.top();
			s.pop();	
		}
	}
	postorder(0,0,n-1);
}

猜你喜欢

转载自blog.csdn.net/LanQiLi/article/details/82712046