PAT(树)——1086 Tree Traversals Again (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/86571957

1086 Tree Traversals Again (25 分)
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

题目大意:

给出一个二叉树栈实现的中序遍历执行过程,求它的后序遍历序列。

题目解析:

中序序列可以由栈操作得到,而数据的输入正好是先序序列。在中序序列里面找到root的位置,左边是左子树,右边是右子树 。

具体代码:

#include<iostream>
#include<algorithm>
#include<stack>
using namespace std;
#define MAXN 50
int pre[MAXN],in[MAXN];
stack<int> s;
void post(int root,int start,int end){
	if(start>end) return;
	int i=start;
	while(i<end&&in[i]!=pre[root]){i++;}//在中序序列里面找到root的位置,左边是左子树,右边是右子树 
//	cout<<pre[root]<<" "<<in[i]<<" "<<pre[root+1]<<" "<<pre[root+i-start+1]<<endl;
	post(root+1,start,i-1);
	post(root+i-start+1,i+1,end);
	if(root!=0)
		printf("%d ",pre[root]);
	else
		printf("%d",pre[root]);
}
int main()
{
	int n,k=0,k0=0;
	cin>>n;
	for(int i=0;i<2*n;i++){
		string str;
		cin>>str;
		if(str=="Push"){
			cin>>pre[k];
			s.push(pre[k]);
			k++;
		}else{
			in[k0]=s.top();
			s.pop();
			k0++;
		}
	}
	post(0,0,n-1);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29978597/article/details/86571957