PAT 1086 Tree Traversals Again (25 分)

1086 Tree Traversals Again (25 分)
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
在这里插入图片描述


Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.


Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1




解析

如果你会写二叉树的非递归前序遍历和中序遍历,那么这题你应该能看出来,Push的顺序是前序遍历,Pop的顺序是中序遍历。(前中后序遍历的非递归写法)。所以:题目变成了知道前序遍历和中序遍历,求后序遍历
模板题:PAT && 树



Code:

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<stack>
#include<string>
#include<vector>
using namespace std;
struct node {
	int data;
	node* lchild, *rchild;
	node(int value) :data(value), lchild(nullptr),rchild(nullptr){
	}
};
vector<int> pre, in, post;
void change(node*& root, int preL, int preR, int inL, int inR) {
	if (preL > preR)
		return;
	root = new node(pre[preL]);
	int i = inL;
	while (i <=inR) {
		if (in[i] == pre[preL])
			break;
		i++;
	}
	int Num = i - inL;
	change(root->lchild, preL + 1, preL + Num, inL, inL + Num - 1);
	change(root->rchild, preL + Num + 1, preR, inL + Num+1, inR);
}
void postorder(node* root) {
	if (root == nullptr)
		return;
	postorder(root->lchild);
	postorder(root->rchild);
	post.push_back(root->data);
}
int main()
{
	int N,x;
	scanf("%d", &N);
	node* root = nullptr;
	stack<int> s;
	string str;
	for (int i = 0; i < 2 * N; i++) {
		cin >> str;
		if ( str.size()==4) {
			scanf("%d", &x);
			s.push(x);
			pre.push_back(s.top());
		}
		else {
			in.push_back(s.top());
			s.pop();
		}
	}
	change(root, 0, N - 1, 0, N - 1);
	postorder(root);
	if (!post.empty()) {
		for (int i = 0; i < N; i++)
			printf("%d%c", post[i], i == N - 1 ? '\n' : ' ');
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/84262010