1.6 [hduoj] 2055 An easy problem

Problem Description

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).

Input

On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output

for each case, you should the result of y+f(x) on a line.

Sample Input

6

R 1

P 2

G 3

r 1

p 2

g 3

Sample Output

19

18

10

-17

-14

-4

#include<stdio.h>
void main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            getchar();
            char c;
            int k;
            scanf("%c%d",&c,&k);
            if(c>='a'&&c<='z')
                printf("%d\n",96+k-(int)c);
            if(c>='A'&&c<='Z')
                printf("%d\n",k+(int)c-64);
            //printf("%d\n",k+z);
        }
    }
}

乍一看这题目的名字,感觉又是迷惑性战术。嗯。看完题目,好像标题的还真没骗人。

哦事实证明,我确实花了很多时间解这题。主要是少了那句getchar() 因为上一次输入的换行符还存在缓冲区里(但是不加这句前好像感觉没影响输出结果这是为啥。)

发布了153 篇原创文章 · 获赞 4 · 访问量 3717

猜你喜欢

转载自blog.csdn.net/qq_39782006/article/details/103850095
今日推荐