HDU-2055 An easy problem

Problem Description

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).

Input

On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output

for each case, you should the result of y+f(x) on a line.

Sample Input

6

R 1

P 2

G 3

r 1

p 2

g 3

Sample Output

19

18

10

-17

-14

-4

代码:

#include <stdio.h>
int main()
{
	int t,n;
	char ch;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		scanf("%c%d",&ch,&n);
		getchar();
		if(ch>='A'&&ch<='Z')
			printf("%d\n",n+ch-'A'+1);
		else
			printf("%d\n",n-(ch-'a'+1));
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/82119160