HDU2055An easy problem

本文章仅用于笔记。部分知识点来源于网络,授权请联系作者([email protected])。



题目


we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26; 
Give you a letter x and a number y , you should output the result of y+f(x).
InputOn the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number. Outputfor each case, you should the result of y+f(x) on a line. Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3
Sample Output
19
18
10
-17
-14
-4


解题


扫描二维码关注公众号,回复: 4327254 查看本文章
import java.util.Scanner;

public class HDU2055
{
//An easy problem
	public static void main(String[] args)
	{
		Scanner s=new Scanner(System.in);
		while(s.hasNextInt())
		{
			int n=s.nextInt();
			for(int i=0;i<n;i++)
			{
				String x=s.next();
				int y=s.nextInt(),shu=0;
				char[] x1=x.toCharArray();
				if(x1[0]>=97&&x1[0]<=122)
					shu=(-x1[0])+y+96;
				else
					shu=x1[0]+y-64;
				System.out.println(shu);
			}
		}

	}

}

求来波关注! 谢谢啦0.0!

小小小作者 
@Fanny0602

猜你喜欢

转载自blog.csdn.net/qq_40833874/article/details/78726448