HDU2055 An easy problem

Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 

Output
for each case, you should the result of y+f(x) on a line.
 

Sample Input
 
  
6 R 1 P 2 G 3 r 1 p 2 g 3
 

Sample Output
 
  
19 18 10 -17 -14 -4
 

#include<stdio.h>
#include<string.h>
int main()
{
   int t;
   scanf("%d",&t);
   getchar();
   char a;
   int b,answer;
   while(t--)
   {
       answer=0;
       scanf("%c%d",&a,&b);
       getchar();
       if(a>='a'&&a<='z')
         answer=-1*((int)a-96);
       else if(a>='A'&&a<='Z')
        answer=(int)a-64;
        printf("%d\n",answer+b);
   }
   return 0;
}

猜你喜欢

转载自blog.csdn.net/narzisen/article/details/80217808