HDU2055_An easy problem

An easy problem


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22126    Accepted Submission(s): 14606


Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 

Output
for each case, you should the result of y+f(x) on a line.
 

Sample Input
 
  
6 R 1 P 2 G 3 r 1 p 2 g 3
 

Sample Output
 
  
19 18 10 -17 -14 -4
 

Author
8600
 

Source

#include <stdio.h>
int main()
{
    int T, y;
    char x;
    scanf("%d%*c",&T);
    while (T--)
    {
        scanf("%c%d%*c",&x,&y);
        if (x>='A'&&x<='Z')
            printf ("%d\n",y+x-'A'+1);
        else
            printf ("%d\n",y+'z'-26-x);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/github_36324732/article/details/53468484