hdu 1051 wooden sticks (贪心+巧妙转化)

Wooden Sticks

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24403    Accepted Submission(s): 9900


ProblemDescription

There is a pile ofn wooden sticks. The length and weight of each stick are known in advance. Thesticks are to be processed by a woodworking machine in one by one fashion. Itneeds some time, called setup time, for the machine to prepare processing a stick.The setup times are associated with cleaning operations and changing tools andshapes in the machine. The setup times of the woodworking machine are given asfollows: 

(a) The setup time for the first wooden stick is 1 minute.
 
(b) Right after processing a stick of length l and weight w , the machine willneed no setup time for a stick of length l' and weight w' if l<=l' andw<=w'. Otherwise, it will need 1 minute for setup.
 

You are to find the minimum setup time to process a given pile of n wooden sticks.For example, if you have five sticks whose pairs of length and weight are(4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

 

Input

The input consistsof T test cases. The number of test cases (T) is given in the first line of theinput file. Each test case consists of two lines: The first line has an integern , 1<=n<=5000, that represents the number of wooden sticks in the testcase, and the second line contains n 2 positive integers l1, w1, l2, w2, ...,ln, wn, each of magnitude at most 10000 , where li and wi are the length andweight of the i th wooden stick, respectively. The 2n integers are delimited byone or more spaces.

 

 

Output

扫描二维码关注公众号,回复: 2165665 查看本文章

The output shouldcontain the minimum setup time in minutes, one per line.

 

 

Sample Input

3

5

4 9 5 2 2 1 3 5 1 4

3

2 2 1 1 2 2

3

1 3 2 2 3 1

 

 

Sample Output

2

1

3



#include <iostream>
#include<stdio.h>
#include<cmath>
#include<algorithm>
using namespace std;
struct product
{
    int w;
    int l;
     bool operator<(product &p2)
    {
        if(w==p2.w)return l<=p2.l;
        else return w<p2.w;
    }
};
product p[5005];
int main()
{
    //freopen("C://Users/kkk/Desktop/acm.txt","r",stdin);
    int test;
    cin>>test;
    while(test--)
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>p[i].w>>p[i].l;
        }
        sort(p,p+n);
        int ans=0;
        bool vis[n];
        for(int i=0;i<n;i++)vis[i]=0;
        for(int i=0;i<n;i++)
        {
            if(vis[i])continue;
            ans++;int preL=p[i].l;
            for(int j=i+1;j<n;j++)
            if(!vis[j]&&p[j].l>=preL){vis[j]=1;preL=p[j].l;}
        }
        cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/linruier2017/article/details/80168551
今日推荐