【PAT】A1020 Tree Traversals (25point(s))

A1020 Tree Traversals (25point(s))

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

Code

#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
int n;
vector<int> inorder(35), levelorder, postorder(35);
struct NODE{
    int data;
    struct NODE *lchild, *rchild;
};
NODE *build(int inl, int inr, int postl, int postr){	// 中序后序建树
    if(postl > postr) return NULL;
    NODE *root = new NODE;
    root->data = postorder[postr];
    int i;
    for(i = inl; i <= inr; i++){
        if(postorder[postr] == inorder[i])
            break;
    }
    int lcnt=i-inl;
    root->lchild = build(inl, i - 1, postl, postl + lcnt - 1);
    root->rchild = build(i + 1, inr, postl + lcnt, postr - 1);
    return root;
}
void lorder(NODE *root){	// 层序遍历
	queue<NODE*> q;
	q.push(root);
	while(!q.empty()){
        NODE *temp=q.front();
        q.pop();
        levelorder.push_back(temp->data);
        if(temp->lchild != NULL)    q.push(temp->lchild);
        if(temp->rchild != NULL)    q.push(temp->rchild);
	}
}
int main(){
	scanf("%d", &n);
	for (int i = 0; i < n; i++) scanf("%d", &postorder[i]);
	for (int i = 0; i < n; i++) scanf("%d", &inorder[i]);
	NODE *root = build(0, n-1, 0, n-1);
	lorder(root);
	for (int i = 0; i < levelorder.size(); i++){	// 按要求输出
        if (i)	printf(" ");
        printf("%d", levelorder[i]);
	}
	printf("\n");
	return 0;
}

Analysis

-已知一棵树的后序和中序遍历序列。

-求树的层序序列。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103759180